Private Key password during boot

Discussion in 'General' started by thomas, Oct 27, 2005.

  1. thomas

    thomas New Member

    I have installed ISPConfig on a Debian box following "The Perfect Setup". During the installation I supplied a password when creating Private Keys for openSSL and/or Sasl. Now when the machine boot I have to use that password else ISPConfig cant start because it cant read the encrypted files.
    This is no problem if I attach a monitor and keyboard to the computer and I stay at the same location as the box, but how do I supply that password remotely?
  2. falko

    falko Super Moderator ISPConfig Developer

    At which stage during the boot process does it ask for the password?
  3. thomas

    thomas New Member

    After I give the password the ordinary linux loginprompt appears and I can login as root!
  4. Lil'Brudder

    Lil'Brudder New Member

    Not selecting 'No' in ISPConfig setup steps 7 and 8?

    I may be mistaken, but in the ISPConfig Setup instructions:

    It says that during the ISPConfig Apache install, if you don't select 'No' during Step 7 and Step 8, that you will have to enter the pass phrase everytime you boot up the computer. Is this what you're referring to?

    *note: this is different than supplying the passphrase during the normal Apache and SSL install.
  5. falko

    falko Super Moderator ISPConfig Developer

    Ahh, you mean that password... I was thinking of something completely different.
    You can use an SSH client such as PuTTY to supply the password, but that works only if you start ISPConfig manually. If the system tries to start/restart ISPConfig then there's a problem.
    The solution might be to install ISPConfig again (without deleting the old installation!), the installer will recognize that it's an update. Follow these instructions: and don't provide a password! :eek:
  6. thomas

    thomas New Member

    Yes my misstake, I didn't read the manual carefully enough regarding step 7 and step 8.
    I will reinstall later on.

    Thank You all for answering my question!
  7. thomas

    thomas New Member

    I have now reinstalled/upgraded ISPConfig from 2.0.9 to 2.1.0 and my problem remains...! During install I answered no in step 7 'n 8. When the installation finished and ISPConfig restarts, it still want the (RSA) passphrase, when I enter the phrase ISPConfig starts and I can login to ISPConfig from a ws. When I reboot the computer
    Apache /1.3.33 mod_ssl /2.8.23 starts this PassPhrase dialog and I have to enter the password.
  8. linuxhelp

    linuxhelp New Member

    Howto disable passphrase Dialog? at boot

    Hi @ALL

    i have setup a new system how can i disable Passphrase dialog?
    at boot or set the password automaticly?

    Thanks Tom
  9. falko

    falko Super Moderator ISPConfig Developer

Share This Page