Printer problems - cups webpage access

Discussion in 'HOWTO-Related Questions' started by Robfitzp, Sep 20, 2011.

  1. Robfitzp

    Robfitzp New Member


    I am a complete linux newbie and have installed vortexbox (media server based on fedora 14) on my old PC.

    I want to set this up as a printer server with a Samsung ML1210 & HP Photosmart 7760 that will be shared via samba to a windows 7 laptop plus a couple of windows work laptops.

    vortexbox does not have a GUI so I have installed webmin to get access from my laptop. I have installed cups (yum install cups) and I also downloaded the HPLIB linux driver for my printer and installed that. Apart from the test page that prints when I first install the driver I can't get it to print a test page. Have not tried the Samsung yet but will do this week.

    I have tried using the \\vortexbox:631 address to access the cups setup webpage from the remote machine but it will not work. I read the howto on here and tried to edit etc\cups\cups.confd but the text in the how to that supposedly blocks access from a remote machine is not present anyway.

    Vortexbox has samba installed and it is working great for files etc. I have added a printer share in webmin, identifying the HP printer and setting available=yes, browsable=yes and I can see the printer listed in the services list along with the shared directories. When I try and add a network printer in windows on the laptop though it cannot find it, either by searching or direct address/printer name.

    Long and the short of it, I don't think the printer is set up properly and am a bit stuck. I am hoping that if I could access the cups webpage it might work but am open to ideas?!?

    Any help for a newbie would be gratefully received, particularly around getting onto the cups website from a remote machine as getting the printer installed properly locally has to be the first step!


Share This Page