Primary Name Server Not Listed At Parent

Discussion in 'ISPConfig 3 Priority Support' started by Enrique García, Dec 21, 2017.

  1. Enrique García

    Enrique García Member HowtoForge Supporter

    I'm install using The Perfect Server CentOS 7.3 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.1.
    But, I can't send and receive emails, the next command "# egrep '(warning|error|fatal|panic):' /var/log/maillog"

    Display me the last messages:
    Dec 21 14:54:07 www dovecot: imap-login: Disconnected (no auth attempts in 1 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<nbem5t9gxAC7o0Sj>
    Dec 21 14:54:07 www dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<8e6s5t9gxQC7o0Sj>

    I'm using let's encrypt with ispconfig, I try removing the check box of SSL, then putting again to check, but do not resolve the problem.

    I check my domains (fyde.com.mx and docente.com.mx) in mxtoosbox.com, and display me the error: "Primary Name Server Not Listed At Parent" (maybe have some relation this errors).

    File pri.docente.com.mx
    $TTL 3600
    @ IN SOA ns.fyde.com.mx. eagarciaj.gmail.com. (
    2017122101 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    3600 ) ; minimum, seconds
    ;

    docente.com.mx. 3600 A 144.217.95.153
    mail 3600 A 144.217.95.153
    ns 3600 A 144.217.95.153
    www 3600 A 144.217.95.153
    docente.com.mx. 3600 MX 10 mail.docente.com.mx.
    docente.com.mx. 3600 NS ns.fyde.com.mx.
    docente.com.mx. 3600 NS sdns1.ovh.ca.
    mail.docente.com.mx 3600 PTR mail
    default._domainkey.docente.com.mx. 3600 TXT "v=DKIM1; t=s; p=MIGfMA0GCSqG.."
    docente.com.mx. 3600 TXT "v=spf1 mx ~all"
    dmarc.docente.com.mx. 3600 TXT "v=DMARC1; p=quarantine"

    File pri.fyde.com.mx
    $TTL 3600
    @ IN SOA ns.fyde.com.mx. eagarciaj.gmail.com. (
    2017092006 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    3600 ) ; minimum, seconds
    ;

    fyde.com.mx. 3600 A 144.217.95.153
    www 3600 A 144.217.95.153
    mail 3600 A 144.217.95.153
    fyde.com.mx. 3600 NS ns.fyde.com.mx.
    fyde.com.mx. 3600 NS sdns1.ovh.ca.
    fyde.com.mx. 3600 MX 10 mail.fyde.com.mx.
    fyde.com.mx. 3600 TXT "v=spf1 mx ~all"
    ns 3600 A 144.217.95.153
    mail.fyde.com.mx 3600 PTR mail
    default._domainkey.fyde.com.mx. 3600 TXT "v=DKIM1; t=s; p=MIGfMA0GCS..."
    dmarc.fyde.com.mx. 3600 TXT "v=DMARC1; p=quarantine; rua=mailto:[email protected]; ruf=mailto:[email protected]"

    Please advice.

    Regards,
     
    Last edited: Dec 21, 2017
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    the domain fyde.com.mx has 2 dns (not one): ns.fyde.com.mx and sdns1.ovh.ca. you must send the changes to / notify sdns1.ovh.ca, too.
     
  3. Enrique García

    Enrique García Member HowtoForge Supporter

    Yes, already done, since sept 4th, 2017 I attach print screen, is that what you mean?
    The file "ovh ps.jpg" is from my Hosting provider and the file "NIC Mexico.jpg" from my registrant.

    It was working but change operating system from Debian 9 to Centos 7, because the Moodle plataform was very problematic with Debian, now with Centos works like a charm. The only problem is the email server, that is not need it for Moodle but desirable. The email server was working, I attach actual print screen from roundcube, so I didn't make anything to fix it until now.

    I was thinking it was a mistake in the SOA.
    Advise,
    Regards,
     

    Attached Files:

  4. Taleman

    Taleman Active Member HowtoForge Supporter

    The name servers are setup wrong. Use som DNS check tool, like http://dnscheck.pingdom.com/ for example.
    Code:
    [email protected]:~$ host sdns1.ovh.ca
    sdns1.ovh.ca has address 8.33.137.137
    [email protected]:~$ ping -c 3  sdns1.ovh.ca
    PING sdns1.ovh.ca (8.33.137.137) 56(84) bytes of data.
    64 bytes from sdns1.ovh.ca (8.33.137.137): icmp_seq=1 ttl=52 time=249 ms
    64 bytes from sdns1.ovh.ca (8.33.137.137): icmp_seq=2 ttl=52 time=275 ms
    64 bytes from sdns1.ovh.ca (8.33.137.137): icmp_seq=3 ttl=52 time=198 ms
    
    --- sdns1.ovh.ca ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2001ms
    rtt min/avg/max/mdev = 198.173/241.055/275.658/32.172 ms
    [email protected]:~$ host fyde.com.mx sdns1.ovh.ca
    Using domain server:
    Name: sdns1.ovh.ca
    Address: 8.33.137.137#53
    Aliases:
    
    Host fyde.com.mx not found: 2(SERVFAIL)
    [email protected]:~$
    
    The log file you egrepped seems to me show that you can not log in to your mail account. I would check username and password.
     
  5. Enrique García

    Enrique García Member HowtoForge Supporter

    Thanks for your kindly responses.
    sdns1.ovh.ca has problems, I already checking with my hosting provider.
    About the mail account. No body uses the email because is not working, the only user is the Moodle (how I can check the user and password Moodle uses?) .
    Every 10 mins (moodle cron) a receive the next error message on console:
    (checking with mutt as root)
    Date: Mon, 25 Dec 2017 13:28:52 -0600 (CST)
    From: Mail Delivery System <[email protected]>
    To: [email protected]
    Subject: Undelivered Mail Returned to Sender

    [-- Attachment #1: Notification --]
    [-- Type: text/plain, Encoding: 7bit, Size: 0.5K --]

    This is the mail system at host www.fyde.com.mx.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <[email protected]> (expanded from <root>): delivery temporarily suspended:
    connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

    [-- Attachment #2: Delivery report --]
    [-- Type: message/delivery-status, Encoding: 7bit, Size: 0.4K --]

    Reporting-MTA: dns; www.fyde.com.mx
    X-Postfix-Queue-ID: C3E2E21891
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Wed, 20 Dec 2017 13:10:02 -0600 (CST)

    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822; root
    Action: failed
    Status: 4.4.1
    Diagnostic-Code: X-Postfix; delivery temporarily suspended: connect to
    127.0.0.1[127.0.0.1]:10024: Connection refused

    [-- Attachment #3: Undelivered Message --]
    [-- Type: message/rfc822, Encoding: 7bit, Size: 8.4K --]

    Date: Wed, 20 Dec 2017 13:10:02 -0600 (CST)
    From: "(Cron Daemon)" <[email protected]>
    To: [email protected]
    Subject: Cron <[email protected]> php /var/www/docente.com.mx/web/ead/admin/cli/cron.php (moodle cron)

    Server Time: Wed, 20 Dec 2017 13:10:01 -0600
    Please advice,
    Regards,
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Websites that run on the same system don't need an email password.

    This error means that amavis is not started. Start amavis. In case it does not start, check the mail.log file for the errors why it fails to start.
     
  7. Enrique García

    Enrique García Member HowtoForge Supporter

    It is strange, it seems that it is not installed. I follow the documentation step by step, with the classic copy&paste. There's no log files.

    [[email protected] log]# find / -name clamav.log
    [[email protected] log]# find / -name amavis.log


    [[email protected] log]# systemctl start clamd
    Failed to start clamd.service: Unit not found.
    [[email protected] log]# netstat -lntp |grep clam
    [[email protected] log]# systemctl status clamd.service
    Unit clamd.service could not be found.

    [[email protected] log]# service amavisd start
    Redirecting to /bin/systemctl start amavisd.service
    Job for amavisd.service failed because the control process exited with error code. See "systemctl status amavisd.service" and "journalctl -xe" for details.
    [[email protected] log]# systemctl status amavisd.service
    ● amavisd.service - Amavisd-new is an interface between MTA and content checkers.
    Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled; vendor preset: disabled)
    Active: failed (Result: start-limit) since Tue 2017-12-26 10:22:47 CST; 5s ago
    Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 5252 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf (code=exited, status=13)

    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: amavisd.service: control process exited, code=exited status=13
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: Unit amavisd.service entered failed state.
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: amavisd.service failed.
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: amavisd.service holdoff time over, scheduling restart.
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: start request repeated too quickly for amavisd.service
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: Unit amavisd.service entered failed state.
    Dec 26 10:22:47 www.fyde.com.mx systemd[1]: amavisd.service failed.

    So, if the problem is with clamav, I remove it:
    yum remove amavisd-new spamassassin clamav-server clamav-data clamav-update clamav-filesystem clamav clamav-scanner-systemd clamav-devel clamav-lib clamav-server-systemd
    systemctl restart postfix


    But, still egrep '(warning|error|fatal|panic):' /var/log/maillog
    Dec 26 11:53:29 www dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<JZ/m9UFhVQC7o0Sj>
    Dec 26 11:53:30 www dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<xrft9UFhVgC7o0Sj>
    Dec 26 11:53:31 www dovecot: imap-login: Disconnected (no auth attempts in 1 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<Dqn49UFhVwC7o0Sj>
    Dec 26 11:53:31 www dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<0N/+9UFhWAC7o0Sj>
    Dec 26 11:53:31 www dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<ha4D9kFhWQC7o0Sj>

    Please advice.
    Regards,
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a bad idea as it completely breaks the mail system, these packages are not optional. Please reinstall them. Then restart amavis and afterwards take a look into the maillog file and post the errors that got added there at the end of the file for the failed amavisrestart.
     
  9. Enrique García

    Enrique García Member HowtoForge Supporter

    Problems at installation.
    [[email protected] ~]# nano /etc/freshclam.conf
    [[email protected] ~]# nano /etc/sysconfig/freshclam
    [[email protected] ~]# sa-update
    [[email protected] ~]# freshclam
    ClamAV update process started at Wed Dec 27 12:27:20 2017
    Downloading main-58.cdiff [100%]
    main.cld updated (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
    WARNING: getfile: daily-21724.cdiff not found on database.clamav.net (IP: 207.210.46.249)
    WARNING: getpatch: Can't download daily-21724.cdiff from database.clamav.net
    WARNING: getfile: daily-21724.cdiff not found on database.clamav.net (IP: 200.236.31.1)
    WARNING: getpatch: Can't download daily-21724.cdiff from database.clamav.net
    WARNING: getfile: daily-21724.cdiff not found on database.clamav.net (IP: 172.255.51.117)
    WARNING: getpatch: Can't download daily-21724.cdiff from database.clamav.net
    WARNING: Incremental update failed, trying to download daily.cvd
    .
    .
    .
    Downloading bytecode-316.cdiff [100%]
    Downloading bytecode-317.cdiff [100%]
    Downloading bytecode-318.cdiff [100%]
    Downloading bytecode-319.cdiff [100%]
    bytecode.cld updated (version: 319, sigs: 75, f-level: 63, builder: neo)
    Database updated (6380003 signatures) from database.clamav.net (IP: 172.255.51.117)
    [[email protected] ~]# systemctl enable amavisd.service
    Created symlink from /etc/systemd/system/multi-user.target.wants/amavisd.service to /usr/lib/systemd/system/amavisd.service.
    [[email protected] ~]# systemctl start amavisd.service
    [[email protected] ~]# systemctl start [email protected]
    [[email protected] ~]# systemctl enable postgrey.service
    [[email protected] ~]# systemctl start postgrey.service

    [[email protected] ~]# egrep '(warning|error|fatal|panic):' /var/log/maillog (the last logs)
    Dec 27 12:30:01 www amavis[10031]: (10031-01) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamd.amavisd/clamd.sock (All attempts (1) failed connecting to /var/run/clamd.amavisd/clamd.sock) at (eval 132) line 659.\n
    Dec 27 12:30:01 www amavis[10030]: (10030-01) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamd.amavisd/clamd.sock (All attempts (1) failed connecting to /var/run/clamd.amavisd/clamd.sock) at (eval 132) line 659.\n

    :(
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not grep in the file for errors as you miss the important lines then. Restart amavis and then look at the end of the maillog file and post the messages that got added for the amavis restart. And try to send an email and post the lines that got added for the mail sending attempt. Most likely amavis is already working and you did not recognize it as the messages that you posted about clamav indicate a working amavis daemon. And in case you reinstalled amavis or postfix or another mail component, then parts of the config might be missing. In that case you have to run an ispconfig update with reconfigure services = yes to fix that.
     
  11. Enrique García

    Enrique García Member HowtoForge Supporter

    [[email protected] ~]# systemctl stop amavisd
    [[email protected] ~]# systemctl start amavisd

    Dec 27 16:05:06 www amavis[20195]: starting. /usr/sbin/amavisd at www.fyde.com.mx amavisd-new-2.11.0 (20160426), Unicode aware, LANG="en_US.UTF-8"
    Dec 27 16:05:06 www amavis[20196]: Net::Server: Group Not Defined. Defaulting to EGID '988 988'
    Dec 27 16:05:06 www amavis[20196]: Net::Server: User Not Defined. Defaulting to EUID '992'
    Dec 27 16:05:06 www amavis[20196]: No ext program for .lz4, tried: lz4c -d
    Dec 27 16:05:06 www amavis[20196]: No ext program for .rar, tried: unrar, rar
    Dec 27 16:05:06 www amavis[20196]: No decoder for .lz4
    Dec 27 16:05:06 www amavis[20196]: Using primary internal av scanner code for ClamAV-clamd
    Dec 27 16:05:06 www amavis[20196]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan

    Sending using roundcube, with sucessfull message to [email protected]

    [email protected]> to=<[email protected]> proto=ESMTP helo=<mx-b.mail.citi.com>
    Dec 27 16:07:23 www postfix/smtpd[20259]: NOQUEUE: reject: RCPT from unknown[67.231.153.94]: 450 4.7.1 <mx-b.mail.citi.com>: Helo command rejected: Host not found; from=<[email protected]ti.com> to=<[email protected]> proto=ESMTP helo=<mx-b.mail.citi.com>
    Dec 27 16:07:23 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20263, secured, session=<ZlS/n1lhygB/AAAB>
    Dec 27 16:07:23 www dovecot: imap([email protected]): Disconnected: Logged out in=32 out=455
    Dec 27 16:07:23 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20265, secured, session=<sdTAn1lhzAB/AAAB>
    Dec 27 16:07:23 www dovecot: imap([email protected]): Disconnected: Logged out in=44 out=562
    Dec 27 16:07:39 www postfix/pickup[18762]: 797151F944: uid=48 from=<[email protected]>
    Dec 27 16:07:39 www postfix/cleanup[20269]: 797151F944: message-id=<[email protected]>
    Dec 27 16:07:39 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20271, secured, session=<eAyxoFlhzgB/AAAB>
    Dec 27 16:07:39 www postfix/qmgr[974]: 797151F944: from=<[email protected]>, size=520, nrcpt=1 (queue active)
    Dec 27 16:07:39 www dovecot: imap([email protected]): Disconnected: Logged out in=456 out=568
    Dec 27 16:07:39 www postfix/smtpd[20275]: connect from localhost[127.0.0.1]
    Dec 27 16:07:39 www postfix/smtpd[20275]: D787F1F87F: client=localhost[127.0.0.1]
    Dec 27 16:07:39 www postfix/cleanup[20269]: D787F1F87F: message-id=<[email protected]>
    Dec 27 16:07:39 www postfix/qmgr[974]: D787F1F87F: from=<[email protected]>, size=951, nrcpt=1 (queue active)
    Dec 27 16:07:39 www amavis[20197]: (20197-01) Passed CLEAN {RelayedOpenRelay}, [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: jMEK5XGG-cgh, Hits: 2.498, size: 520, queued_as: D787F1F87F, 376 ms
    Dec 27 16:07:39 www postfix/smtp[20272]: 797151F944: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.44, delays=0.04/0.02/0.02/0.37, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as D787F1F87F)
    Dec 27 16:07:39 www postfix/qmgr[974]: 797151F944: removed
    Dec 27 16:07:39 www postfix/smtp[20276]: connect to gmail-smtp-in.l.google.com[2607:f8b0:400d:c08::1a]:25: Network is unreachable
    Dec 27 16:07:40 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20278, secured, session=<pxe9oFlh3gB/AAAB>
    Dec 27 16:07:40 www dovecot: imap([email protected]): Disconnected: Logged out in=70 out=582
    Dec 27 16:07:40 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20280, secured, session=<tSzDoFlh4AB/AAAB>
    Dec 27 16:07:40 www dovecot: imap([email protected]): Disconnected: Logged out in=432 out=25696
    Dec 27 16:07:40 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20282, secured, session=<Cy/FoFlh4gB/AAAB>
    Dec 27 16:07:40 www postfix/smtp[20276]: D787F1F87F: to=<[email protected]>, relay=gmail-smtp-in.l.google.com[173.194.206.26]:25, delay=0.95, delays=0.01/0.03/0.23/0.68, dsn=2.0.0, status=sent (250 2.0.0 OK 1514412460 b6si3763959qkd.372 - gsmtp)
    Dec 27 16:07:40 www postfix/qmgr[974]: D787F1F87F: removed
    Dec 27 16:07:40 www dovecot: imap([email protected]): Disconnected: Logged out in=233 out=893
    Dec 27 16:07:49 www postfix/smtpd[20283]: connect from unknown[142.0.81.165]
    Dec 27 16:07:49 www postfix/smtpd[20283]: NOQUEUE: filter: RCPT from unknown[142.0.81.165]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<vmta-i-165.lstrk.net>
    Dec 27 16:07:49 www postfix/smtpd[20283]: NOQUEUE: filter: RCPT from unknown[142.0.81.165]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<vmta-i-165.lstrk.net>
    Dec 27 16:07:49 www postfix/smtpd[20283]: NOQUEUE: reject: RCPT from unknown[142.0.81.165]: 450 4.7.1 <vmta-i-165.lstrk.net>: Helo comma
    and rejected: Host not found; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<vmta-i-165.lstrk.net>
    Dec 27 16:07:49 www postfix/smtpd[20283]: disconnect from unknown[142.0.81.165]
     
  12. Enrique García

    Enrique García Member HowtoForge Supporter

    I make a fresh install Centos 7 and amavis install with no problems but when I update ispconfig from 3.1dev to 3.1.10 :
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3.1.10.tar.gz
    tar xvfz ISPConfig-3.1.10.tar.gz
    cd ispconfig3_install/install
    php -q update.php

    At the end display:
    Restarting services ...
    Job for amavisd.service failed because the control process exited with error code. See "systemctl status amavisd.service" and "journalctl -xe" for details.
    Update finished.

    So, I think the problem is the update, the amvisd.service was installed with no problems.

    Please advise.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the /var/log/maillog file, the amavis start error should be listed there.
     
  14. Enrique García

    Enrique García Member HowtoForge Supporter

    Sorry, I make a fresh install and working with the 3.1dev
    But, when I send an email this is the log:
    Jan 9 14:39:18 www postfix/qmgr[31430]: 2021C22211: from=<[email protected]ti.com>, size=6853, nrcpt=1 (queue active)
    Jan 9 14:39:18 www postfix/qmgr[31430]: 2F4FE223BE: from=<[email protected]>, size=545, nrcpt=1 (queue active)
    Jan 9 14:39:18 www postfix/qmgr[31430]: 4723C22212: from=<[email protected]>, size=2625, nrcpt=1 (queue active)
    Jan 9 14:39:18 www postfix/qmgr[31430]: 4AFFB22215: from=<[email protected]>, size=2593, nrcpt=1 (queue active)
    Jan 9 14:39:18 www postfix/qmgr[31430]: B8596223B4: from=<[email protected]>, size=539, nrcpt=1 (queue active)
    Jan 9 14:39:18 www postfix/qmgr[31430]: 70F9921E7D: from=<[email protected]ti.com>, size=1680535, nrcpt=1 (queue active)
    Jan 9 14:39:18 www postfix/smtp[31687]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jan 9 14:39:18 www postfix/smtp[31688]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jan 9 14:39:18 www postfix/smtp[31687]: 2021C22211: to=<[email protected]>, relay=none, delay=1963, delays=1963/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:18 www postfix/smtp[31688]: 2F4FE223BE: to=<[email protected]>, relay=none, delay=1276, delays=1276/0.03/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:18 www postfix/smtp[31687]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jan 9 14:39:18 www postfix/smtp[31688]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jan 9 14:39:18 www postfix/smtp[31688]: 4AFFB22215: to=<[email protected]>, relay=none, delay=1235, delays=1235/0.04/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:18 www postfix/smtp[31687]: 4723C22212: to=<[email protected]>, relay=none, delay=1243, delays=1243/0.04/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:18 www postfix/error[31692]: B8596223B4: to=<[email protected]>, relay=none, delay=1299, delays=1299/0.06/0/0.01, dsn=4.4.1, st
    atus=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:18 www postfix/error[31693]: 70F9921E7D: to=<[email protected]>, relay=none, delay=50968, delays=50968/0.06/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:22 www postfix/pickup[31429]: BA18B223C5: uid=48 from=<[email protected]>
    Jan 9 14:39:22 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=31699, secured, session=<3vfq6F1iPAAAAAAAAAAAAAAAAAAAAAAB>
    Jan 9 14:39:22 www postfix/cleanup[31696]: BA18B223C5: message-id=<[email protected]>
    Jan 9 14:39:22 www postfix/qmgr[31430]: BA18B223C5: from=<[email protected]>, size=514, nrcpt=1 (queue active)
    Jan 9 14:39:22 www postfix/error[31692]: BA18B223C5: to=<[email protected]>, relay=none, delay=0.07, delays=0.07/0/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 9 14:39:22 www dovecot: imap([email protected]): Disconnected: Logged out in=450 out=568
    Jan 9 14:39:23 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=31702, secured, session=<djj26F1iQAAAAAAAAAAAAAAAAAAAAAAB>
    Jan 9 14:39:23 www dovecot: imap([email protected]): Disconnected: Logged out in=70 out=582
    Jan 9 14:39:23 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=31704, secured, session=<3oT86F1iQgAAAAAAAAAAAAAAAAAAAAAB>
    Jan 9 14:39:23 www dovecot: imap([email protected]): Disconnected: Logged out in=76 out=495
    Jan 9 14:39:24 www dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=31706, secured, session=<+c7+6F1iRAAAAAAAAAAAAAAAAAAAAAAB>
    Jan 9 14:39:24 www dovecot: imap([email protected]): Disconnected: Logged out in=120 out=694
    [[email protected] ~]#

    Please advise,
     
  15. Enrique García

    Enrique García Member HowtoForge Supporter

    This is my master.cf
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - n - - smtpd
    #smtp inet n - n - 1 postscreen
    #smtpd pass - - n - - smtpd
    #dnsblog unix - - n - 0 dnsblog
    #tlsproxy unix - - n - 0 tlsproxy
    #submission inet n - n - - smtpd
    submission inet n - - - - smtpd
    -o syslog_name=postfix/submission
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    # -o smtpd_reject_unlisted_recipient=no
    # -o smtpd_client_restrictions=$mua_client_restrictions
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o smtpd_helo_restrictions=$mua_helo_restrictions
    # -o smtpd_sender_restrictions=$mua_sender_restrictions
    # -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #smtps inet n - n - - smtpd
    smtps inet n - - - - smtpd
    -o syslog_name=postfix/smtps
    -o smtpd_tls_wrappermode=yes
    -o smtpd_sasl_auth_enable=yes
    # -o smtpd_reject_unlisted_recipient=no
    # -o smtpd_client_restrictions=$mua_client_restrictions
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o smtpd_helo_restrictions=$mua_helo_restrictions
    # -o smtpd_sender_restrictions=$mua_sender_restrictions
    # -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - n - - qmqpd
    pickup unix n - n 60 1 pickup
    cleanup unix n - n - 0 cleanup
    qmgr unix n - n 300 1 qmgr
    #qmgr unix n - n 300 1 oqmgr
    tlsmgr unix - - n 1000? 1 tlsmgr
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Amavis is not started and that's why email sending and receiving fails. The log part you posted does not contain the amavis start or restart. Please restart amavis and then take a look into the log again and post the lines that got added for the restart attempt.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Today I made a test install of the CentOS 7.3 tutorial and amavis works fine here. May you please run these commands and post the result:

    hostname
    hostname -f
     
  18. Enrique García

    Enrique García Member HowtoForge Supporter

    I just gave an account, I'm using Centos 7.4, because is a VPS from ovh.com

    [[email protected] ~]# amavisd reload
    Config file "/etc/amavisd.conf" does not exist, at /usr/sbin/amavisd line 2212.
    [[email protected] ~]# ln -s /etc/amavisd/amavisd.conf /etc/amavisd.conf
    [[email protected] ~]# amavisd reload
    The amavisd daemon is apparently not running, no PID file /var/run/amavisd/amavisd.pid

    log:
    Jan 10 12:29:42 www dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=187.163.68.163, lip=144.217.95.153, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<G88LN3BijwC7o0Sj>
    Jan 10 12:30:02 www postfix/smtpd[2377]: connect from unknown[::1]
    Jan 10 12:30:02 www postfix/smtpd[2377]: lost connection after CONNECT from unknown[::1]
    Jan 10 12:30:02 www postfix/smtpd[2377]: disconnect from unknown[::1]
    Jan 10 12:30:02 www dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<x2s4OHBiSgAAAAAAAAAAAAAAAAAAAAAB>
    Jan 10 12:30:02 www dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<YZI4OHBiugAAAAAAAAAAAAAAAAAAAAAB>
    Jan 10 12:30:05 www postfix/smtpd[2377]: connect from unknown[67.231.145.106]
    Jan 10 12:30:05 www postfix/smtpd[2377]: NOQUEUE: filter: RCPT from unknown[67.231.145.106]: <[email protected]ti.com>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]ti.com> to=<[email protected]> proto=ESMTP helo=<mx-a.mail.citi.com>
    Jan 10 12:30:05 www postfix/smtpd[2377]: NOQUEUE: filter: RCPT from unknown[67.231.145.106]: <[email protected]ti.com>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]ti.com> to=<[email protected]> proto=ESMTP helo=<mx-a.mail.citi.com>
    Jan 10 12:30:05 www postfix/smtpd[2377]: warning: 106.145.231.67.zen.spamhaus.org: RBL lookup error: Host or domain name not found. Name service error for name=106.145.231.67.zen.spamhaus.org type=A: Host not found, try again
    Jan 10 12:30:05 www postfix/smtpd[2377]: NOQUEUE: reject: RCPT from unknown[67.231.145.106]: 450 4.7.1 <mx-a.mail.citi.com>: Helo command rejected: Host not found; from=<[email protected]ti.com> to=<[email protected]> proto=ESMTP helo=<mx-a.mail.citi.com>
     
  19. Enrique García

    Enrique García Member HowtoForge Supporter

  20. till

    till Super Moderator Staff Member ISPConfig Developer

    That's fine, the setp works on CentOS 7.3 and 7.4.

    Really strange as this symlink has not to be set manually, neither on CentOS 7.3 nor 7.4.

    Are you sure that you followed the tutorial until the last page and that you have ISPConfig fully installed?

    The hostname is fine.

    And your srver seems to have problems with resolving domain names in DNS.
     
    Last edited: Jan 10, 2018

Share This Page