Prevent certificate warning when SSL is disabled for a client site

Discussion in 'General' started by DamienD, Sep 23, 2015.

  1. DamienD

    DamienD New Member


    Sorry if this has already been asked but I could not find an answer in the forum.

    I have a ISPConfig 3 installation running on debian wheezy.

    In order to secure access to phpmyadmin and roundcube (aliases), I'm using a SSl certificate on the default SSL vhost (/sites-available/default-ssl).

    It's working fine, but how can I prevent the certificate warning when accessing a client website with https ?

    When a client has it's own certificate, no problem, the domain match the client certificate so it works fine but if SSL is not enabled for the client's site then the warning is thrown (because it's using the default certificate).

    Is it possible to completly disable the site https access when SSL is disabled ?

    What would be the best scenario for this situation ?

    Thank you.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You need a second IP address, put all ssl sites on one IP and all non ssl sites on the other IP.
    DamienD likes this.
  3. DamienD

    DamienD New Member

    Thank you ! I don't know why but when I do that. I have an endless redirect loop when i try to access a site with http. Any ideas ?
    Also all sites are redirected to the first site and then loop.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you select the right IP in all sites and that you changed all dns records and waited 24 hours until they propagated.
  5. DamienD

    DamienD New Member

    I did check IP addresses and my dns records are fine. Actually it's working fine when I configure all sites with the wildcard IP address.

Share This Page