Prestashop on ubuntu14.04.2 LTS with LAMP + ISPCONFIG 3.05.4

Discussion in 'HOWTO-Related Questions' started by tips, Apr 11, 2015.

  1. tips

    tips New Member

    I have installed prestashop on Ubuntu server 14.04.2 LTS (LAMP Server) with ispconfig 3.05.4.
    Installation is succesfull, database connected to MySQL no problems.
    When I try and go to back office or shop front all I am getting is error 500, page can not be displayed.
    Any advice or guidance would be most appreciated.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the error.log of the website.
     
  3. tips

    tips New Member

    have had a look in all the logs, nothing seems to me to be wrong.
    what specifically should I be looking for?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    When you get a 500 error then the error must be logged with a more specific error description in the error.log of that website where the error occurred. You should also try to dectivate the custom errr pages for that website in ispconfig, maybe it is a soft error from prestashop and not a real 500 error from the webserver.
     
  5. tips

    tips New Member

    this is now the error that I am getting in the log file:
    [Wed Apr 15 17:50:23.905184 2015] [fcgid:warn] [pid 8314] (104)Connection reset by peer: [client 82.17.45.160:56499] mod_fcgid: error reading data from FastCGI server
    [Wed Apr 15 17:50:23.905245 2015] [core:error] [pid 8314] [client 82.17.45.160:56499] End of script output before headers: index.php

    any help will be appreciated.
     
  6. kwickcut

    kwickcut Member

    i had a similar issue
    by adding FcgidBusyTimeout it fixed the issue.
    this is what i added to my apache.conf:

    Code:
    <VirtualHost *:80>
    .......
    <IfModulemod_fcgid.c>
    FcgidBusyTimeout 3600
    </IfModule></VirtualHost>
    this may be worth looking into


    kwick
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This can be any kind of fatal php error. Did you deactivate the custom error pages in ispconfig? which exact error message do you get in the browser then.
     
  8. tips

    tips New Member

    I have disabled the custom pages, this is what comes up:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator at webmaster@*********.co.uk to inform them of the time this error occurred, and the actions you performed just before this error.
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    What should the php settings for this site be in ispconfig, it is currently set to Fast-cgi?
     

Share This Page