Postmaster problem with Ubuntu 8.04 Postfix Virtual Domains and users

Discussion in 'HOWTO-Related Questions' started by almeister9, Feb 17, 2009.

  1. almeister9

    almeister9 New Member

    RESOLVED: Postmaster problem with Ubuntu 8.04 Postfix Virtual Domains and users

    Hi all,

    I have recently (a couple of months ago) built a Postfix mail server on Ubuntu 8.04 using Falko's excellent howto.

    Everything has been working fine so far. I have an email address called newsletter that I use to send newsletters, which receives bounce messages and replies, another email address called unsubscribe, which receives unsubscribe requests. I have also recently added an email address called postmaster. I am enrolling in microsofts JMRP Program to help my chances of being able to send to hotmail accounts and also their SNDS program.

    I can log into the postmaster account using squirrelmail and the original Welcome message that I sent to it to create the directory is there. I can also send from it to any address I wish, inside or outside the domain.

    I can receive emails sent from addresses within the domain but I cannot, however, receive from addresses outside the domain. I have tried from several different external addresses and nothing shows up.

    When I initially ssh into my server and log into (username) the prompt often tels me "you have new mail". I type "mail to check it and delete it.

    during the initial setup I did do this part of the howto
    Code:
    8 Modify /etc/aliases
    
    Now we should open /etc/aliases. Make sure that postmaster points to root and root to your own username or your email address, e.g. like this:
    
    vi /etc/aliases
    
    [...]
    postmaster: root
    root: postmaster@yourdomain.tld
    [...]
    
    or like this (if administrator is your own username):
    
    [...]
    postmaster: root
    root:   administrator
    [...]
    
    Whenever you modify /etc/aliases, you must run
    
    newaliases
    
    afterwards and restart Postfix:
    
    /etc/init.d/postfix restart 
    mine intitially looked like this:

    Code:
    [...]
    postmaster: root
    root:  alan
    [...]
    I have tried to change it to this

    Code:
    [...]
    postmaster: root
    root: postmaster@myfqdn
    [...]
    but either way I still cannot receive emails into the postmaster account, or if I am, I dont know how to find them. I have been using squirrel mail, is there something that I need to know about the postmaster account?

    thank you in advance to any who can spare the time.
    Cheers
    Al.
     
    Last edited: Feb 19, 2009
  2. falko

    falko Super Moderator

    postmaster is a system user, that's why the virtual mailbox doesn't work. postmaster emails are sent to the root account (because of /etc/aliases).
     
  3. almeister9

    almeister9 New Member

    Re root account

    Thanks for your reply Falko,

    If I log in as root
    and type mail
    I get
    no mail for root

    how do I read emails sent to postmaster?
     
  4. almeister9

    almeister9 New Member

    RESOLVED. (my bad)

    Thanks for your help Falko,

    I discovered that I wasn't receiving emails in any of the accounts.
    My modem/Router had dropped the port forwarding.
    Re-did the port forwarding and everything is OK now.

    D-Link DSL-G604T (wireless turned off)

    I will keep an eye on it and if it happens again I will replace it.:eek:
     

Share This Page