Postmaster Email Problem

Discussion in 'General' started by Alam, Feb 16, 2008.

  1. Alam

    Alam New Member

    Hello People

    I have a minor problem with my emails in ISPConfig something I cant get my head around, I have 2 domains in ISPConfig, Domain1 has postmaster@domain1.tld address and abuse alias works fine even passes the DNS Test,

    It is the Domain2 where I am having problems configured exactly same as domain1, I have a postmaster@domain2.tld and alias abuse configured now I can send and recv email no problem but when i do DNS test on the domain it tells me domain2.tld cannot recv email for postmaster and abuse.

    Any help with on this will be really appreciated.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Is the email address postmaster@domain2.tld listed in /etc/postfix/virtusertable? Are you really sure that the MX record for domain2.com points to this server?
     
  3. Alam

    Alam New Member

    Hi Till

    thank you very much for your reply I am 100% sure the email address for postmaster@domain2.tld is listed in /etc/postfix/virtusertable & I am 100% sure it is pointing to the right mail server.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please run
    Code:
    dig mx domain2.tld
    and make sure that it points to the right server.
     
  5. Alam

    Alam New Member

  6. Alam

    Alam New Member

    Posmaster email problem

    I have resolved the problem ..... Thanks to Till & falko who invested their time in reading my query.
     
  7. sygram

    sygram New Member

    why not share the solution ? ;)

    We might need it someday as well :)

    Thanks

    Regards,

    Leon
     
  8. Alam

    Alam New Member

    Hi Leon
    Thanks for taking interest.

    I am more than happy to do that, it was nothing to do with ISPConfig or any other configuration related to postfix, the culprit was ASSP it was blocking (postmaster & abuse)emails to that particular domain, Hence in ASSP you need to list the domain in the local doamins file & you have to do that everytime you add a new domain to CP.

    Hope that helps :)
     
  9. sygram

    sygram New Member

    Hi Alam,

    i appreciate your answer.

    Although i do not get all bits, i am sure that i will find it useful in the future :)

    Regards,

    Leon
     

Share This Page