postix pop3 help

Discussion in 'HOWTO-Related Questions' started by <=bullet=>, Apr 9, 2007.

  1. <=bullet=>

    <=bullet=> New Member

    I have to install sendmail on a debian sarge distribution and I've been having some serious problems. I was having so many problems, in fact, I decided that I would install postfix instead, seeing as there are a lot more references to postfix than sendmail. I have postfix installed, I have pop3 and imap installed (I installed them both as a sort of failsafe) and everything is working fine. I can telnet into port 25, "ehlo" myself (localhost) and get the right messages, get the right "mail from" and "rcpt to" but it still won't bloody send the mail. It queue's it and doesn't deliver it. I get this message:

    250 Ok: queued as D2E6FADA68

    I've been sending from root to root on the same damn machine and it still won't receive any mail. I've been working on this for a few weeks (on and off) and I can't get it to work.

    It seems to me that the delivery agent isn't working but I have no freaking clue how to fix that. It seems to me the mail is getting sent using the mail transfer client using SMTP but it's not directing it to the right mail boxes. I'm thinking it's something to do with the right directories not being available to my mail client but I have absolutely no clue whether I'm correct in thinking that and, even if I am correct, how to fix it.

    I'd really appreciate any help, I'm about to start pulling my hair out pretty quick.

    btw: I used this how to and copied and pasted EVERYTHING so I don't think it's that... I may be wrong though. seriously, any help would be awesome!

    Thanks in advance,
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    netstat -tap
    ? What's in /etc/postfix/
    Any errors in your mail log?

Share This Page