Postifx configuration problem, no route to host

Discussion in 'Server Operation' started by maortega, Feb 28, 2008.

  1. maortega

    maortega New Member

    I've successfully installed an Ubuntu Server 7.1 with ISPConfig as the hosting panel, i've set up a new site and was trying to install the PHPMotion platform...

    Everything looks to be fine, but when i try to create a new account, it is supposed to send a confirmation email...

    I think there's a problem with the postfix configuration... since my ISP has blocked port 25 i've changed the configuration to use port 26....

    But i still can't send smails...

    Here's the sudo netstat -tap result:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     15608/mysqld
    tcp        0      0 *:www                   *:*                     LISTEN     4091/apache2
    tcp        0      0 *:81                    *:*                     LISTEN     24647/ispconfig_htt
    tcp        0      0 *:ftp                   *:*                     LISTEN     27937/proftpd: (acc
    tcp        0      0 *:26                    *:*                     LISTEN     3830/master
    tcp        0      0 *:https                 *:*                     LISTEN     4091/apache2
    tcp6       0      0 *:imaps                 *:*                     LISTEN     13151/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     13058/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     12991/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     13094/couriertcpd
    tcp6       0      0 *:ssh                   *:*                     LISTEN     10385/sshd
    tcp6       0      0 *:26                    *:*                     LISTEN     3830/master
    tcp6       0    548 maortega:4185           ESTABLISHED3582/sshd: administ
    And here is the sudo sendmail -bp result:
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    D1B8CCF8BC     1337 Thu Feb 28 03:00:31  [email protected]
                       (connect to[]: No route to host)
                                             [email protected]
    01D6FCF8C0     1337 Thu Feb 28 01:42:57  [email protected]
                     (connect to[]: No route to host)
                                             [email protected]
    -- 4 Kbytes in 2 Requests.
    What do you recommend me to do now?

  2. topdog

    topdog New Member HowtoForge Supporter

    if your ISP has blocked port 25 outbound then your setup will never work, changing your local postfix to port 26 is not going to help you as the servers you are trying to send mail to are listening on port 25.

    Why dont you use your ISP as a relayhost ?
  3. maortega

    maortega New Member

    Relay host

    Thanks for the response, i'll search a how to on doing what suggested.

    I'll come back to post the results...
  4. falko

    falko Super Moderator ISPConfig Developer

  5. maortega

    maortega New Member


    Thanks for the link. I should try it and come back with the results.

Share This Page