Postfixadmin + vacation, not working

Discussion in 'Server Operation' started by garson, Dec 26, 2012.

  1. garson

    garson New Member

    Hi.
    I have Ubuntu 11.04, postfix, dovecot, postfixadmin, and 3 webmails, Horde, Squirrelmail and Roundcube.
    Everything is working as expected, but few days ago I have added vacation to postfixadmin.
    I was setting it up according to this How to.
    http://postfixmail.com/blog/index.php/vacation-option-with-postfixadmin/

    So, when I try to send email from [email protected] to [email protected] which has vacation enabled, user1 doesn't get any email. :confused: Nothing happens.

    This is what I get in /var/log/mail.log


    And this is from /var/log/vacation.log
    /var/log/vacation.debug is empty.

    Does anybody knows what could be the problem?

    Thanks.
     
  2. sremac

    sremac New Member

    Same error at my side

    Hi,

    I am experiencing the same error, platform is Centos + Amavisd + Dovecot.

    I see mails are properly arriving to postfix and redirected to vacation domain, but vacation mail is not sent:

    ...
    to=<vacation@domain>, relay=dovecot, delay=0.16, delays=0.02/0.01/0/0.13, dsn=2.0.0, status=sent (delivered via dovecot service)
    Jan 14 21:05:59 ip-10-226-109-205 postfix/pipe[10074]: 3FA9CC1F8: to=<[email protected]>, relay=vacation, delay=0.31, delays=0.02/0.02/0/0.26, dsn=2.0.0, status=sent (delivered via vacation service)
    Jan 14 21:05:59 ip-10-226-109-205 postfix/qmgr[10056]: 3FA9CC1F8: removed
    ...

    I have put into /etc/hosts entry for my public IP:

    IP autoreply.domain2

    but it is the same.

    Any ideas, anyone?

    Thanks
     
  3. shiwu

    shiwu New Member

    I encountered the same problem when trying configure following configuration:

    Distribitution: CentOS release 6.4 (Final) + updates
    postfix: 2.2.el6_1
    Roundcube: 0.8.6
    postfixadmin: 2.3.6

    Perl modules required for vacation.pl were installed from EPEL. To do create new yum repo config file /etc/yum.repos.d/epel.repo:


    After every new mail was sent to email address, which had vacation active, in vacation log file the last entry was always:

    I spent a lot of time tracking the source of the problem. Finally I downloaded the lates available vacation.pl (version 4.0r1) script from that URL:
    http://svn.code.sf.net/p/postfixadmin/code/trunk/VIRTUAL_VACATION/vacation.pl

    After some searching I found that when return in line 490 is commented out the vacation start working fine. It seems that So open vacation.pl and find part of code containing:

    When return is commented out, script do not ends in this if statement, and is continuing further till sending vacation message. after script modification I have now in vacation log file:

    I have also implement some more changes in vacation.pl script, which maybe useful:

     
  4. sushil

    sushil New Member

    Vacation error

    I have the same setup with Centos +Amavis+Dovecot

    Even after commenting out the line

    $logger->debug("Already notified $email, or some error prevented us from doing so");
    it doesn't work for me.

    Regards,
    Sushil
     

Share This Page