Postfix with smtps fails (port 465)

Discussion in 'Server Operation' started by disasm, May 28, 2006.

  1. disasm

    disasm ISPConfig Developer

    Postfix works fine with TLS on port 25, but when connecting on 465, it disconnects right away, and leaves this in the log file:

    Code:
    May 28 16:01:25 localhost postfix/smtpd[5735]: warning: connect to private/tlsmgr: Connection refused
    May 28 16:01:25 localhost postfix/smtpd[5735]: warning: problem talking to server private/tlsmgr: Connection refused
    May 28 16:01:26 localhost postfix/smtpd[5735]: warning: connect to private/tlsmgr: Connection refused
    May 28 16:01:26 localhost postfix/smtpd[5735]: warning: problem talking to server private/tlsmgr: Connection refused
    May 28 16:01:26 localhost postfix/smtpd[5735]: warning: no entropy for TLS key generation: disabling TLS support
    May 28 16:01:26 localhost postfix/smtpd[5735]: connect from localhost.localdomain[127.0.0.1]
    May 28 16:01:26 localhost postfix/smtpd[5735]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    May 28 16:01:26 localhost postfix/smtpd[5735]: Could not allocate 'TLScontext->con' with SSL_new()
    May 28 16:01:26 localhost postfix/smtpd[5735]: warning: TLS library problem: 5735:error:140BA0C3:SSL routines:SSL_new:null ssl ctx:ssl_lib.c:231:
    May 28 16:01:26 localhost postfix/smtpd[5735]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    May 28 16:01:26 localhost postfix/smtpd[5735]: disconnect from localhost.localdomain[127.0.0.1]
    master.cf has these important lines:

    Code:
    # only used by postfix-tls                                                                                                                                                            
    tlsmgr    fifo  -   -   n   300 1   tlsmgr                                                                                                                                            
    smtps     inet  n   -   n   -   -   smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes                                                                                  
    587   inet  n   -   n   -   -   smtpd -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
    
     
  2. falko

    falko Super Moderator

    The error should be gone if you comment out
    Code:
    tlsmgr    fifo  -   -   n   300 1   tlsmgr
     

Share This Page