Postfix With SMTP-AUTH And TLS

Discussion in 'Server Operation' started by James E, Nov 14, 2007.

  1. James E

    James E New Member

    Hello,
    I'am using the tutorial:The Perfect Setup - Ubuntu Feisty Fawn (Ubuntu 7.04) - Page 5.

    When "installing Postfix With SMTP-AUTH And TLS" the tutorial says to run the command:"apt-get install postfix libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail"

    This is the outcome:"[email protected]:/home/server1# apt-get install postfix libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libsasl2 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    libsasl2-2
    E: Package libsasl2 has no installation candidate
    [email protected]:/home/server1#
    [email protected]:/home/server1#

    What does "E: Package libsasl2 has no installation candidate" mean??

    I would be great if you could help me,
    PS: I'am running ubuntu and have followed the instructions completely up to this.

    Thanks,
    James E:)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    apt-get update
    and try again. If you still get that error, replace libsasl2 with libsasl2-2.
     
  3. James E

    James E New Member

    It Worked!

    Hi Falko,
    Thanks, I added -2 to the command and it worked,
    But when installing ISPconfig I get this message:
    Debian lenny/sid.0
    ERROR: Ihr Betriebssystem wird nicht unterst´┐Żtzt! / Your operating system is not supported! / Votre systeme d'exploitation n'est pas support
    [email protected]:~/install_ispconfig#

    Do I need to modify the "dist.txt" file if so how do I do it?

    Thanks,
    James
     
    Last edited: Nov 15, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you download the latest ISPConfig version (2.2.18)?
     

Share This Page