Postfix/Virtual users

Discussion in 'Installation/Configuration' started by Bodger, May 14, 2006.

  1. Bodger

    Bodger New Member

    I have no idea how to fix this.

    I have an ISPClient jlbprof, with a site called, I am not interested in the website, only the mail system.

    It is setup like so:

    Email Address: [email protected]
    Username: web2_julian

    I probably have something wrong in postfix because when someone from the outside tries to email [email protected] they get this in response:

    I intend to web and email host for many domain, how come it is rewriting my email to be [email protected]ldomain?



    This is the Postfix program at host localhost.localdomain.

    I'm sorry to have to inform you that your message could not be
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <[email protected]> (expanded from <[email protected]>): mail
    for localhost.localdomain loops back to myself

    Reporting-MTA: dns; localhost.localdomain
    X-Postfix-Queue-ID: 58099B3B58
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Sat, 13 May 2006 17:15:47 -0500 (CDT)

    Final-Recipient: rfc822; [email protected]ldomain
    Original-Recipient: rfc822; [email protected]
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; mail for localhost.localdomain loops back to myself
  2. falko

    falko Super Moderator ISPConfig Developer

    Please add localhost.localdomain to the mydestination line in /etc/postfix/ and restart Postfix.

Share This Page