postfix virtual users on debian etch

Discussion in 'HOWTO-Related Questions' started by macorama, May 20, 2008.

  1. macorama

    macorama New Member

    Hello!

    I've also followed the tutorial with no problem. (http://www.howtoforge.com/virtual_users_and_domains_with_postfix_debian_etch)
    But after I was done I couldn't login with imap nor pop3. All I get with telnet is:

    Code:
    Trying <IP>...
    Connected to <HOST>.
    Escape character is '^]'.
    +OK Hello there.
    [email protected]
    pass test
    -ERR Temporary problem, please try again later
    Connection closed by foreign host.
    
    Checking my /etc/log/mail.log I get this:
    Code:
    May 19 22:50:20 b098 courierpop3login: Connection, ip=[::ffff:84.168.27.40]
    May 19 22:50:39 b098 authdaemond: authmysql: MYSQL_USERNAME not set in /etc/courier/authmysqlrc.
    May 19 22:50:39 b098 courierpop3login: LOGIN FAILED, [email protected], ip=[::ffff:84.168.27.40]
    May 19 22:50:39 b098 courierpop3login: authentication error: Input/output error
    From this, I check my /etc/courier/authmysqlrc
    Code:
    MYSQL_SERVER 127.0.0.1 # tried also localhost, same problem
    MYSQL_USERNAME mail_admin
    MYSQL_PASSWORD test
    MYSQL_PORT 0
    MYSQL_DATABASE mail
    MYSQL_USER_TABLE users
    MYSQL_CRYPT_PWFIELD password
    #MYSQL_CLEAR_PWFIELD password
    MYSQL_UID_FIELD 5000
    MYSQL_GID_FIELD 5000
    MYSQL_LOGIN_FIELD email
    MYSQL_HOME_FIELD "/home/vmail"
    MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
    #MYSQL_NAME_FIELD
    MYSQL_QUOTA_FIELD quota
    I'm clueless. Does anyone has an idea?

    Best regards,
    Daniel

    BTW: I edit all files on a Mac. For line end I use LF and encoding is UTF-8. Shouldn't be a problem, should it?

    This is an excerpt from my /etc/log/mail.log:
    Code:
    May 20 13:03:23 b098 postfix/smtpd[21693]: connect from 218-160-110-48.dynamic.hinet.net[218.160.110.48]
    May 20 13:03:24 b098 postfix/smtpd[21696]: connect from mail.gmx.net[213.165.64.20]
    May 20 13:03:24 b098 postfix/smtpd[21696]: 68545274209: client=mail.gmx.net[213.165.64.20]
    May 20 13:03:24 b098 postfix/cleanup[21701]: 68545274209: message-id=<[email protected]>
    May 20 13:03:24 b098 postfix/qmgr[21637]: 68545274209: from=<[email protected]>, size=935, nrcpt=1 (queue active)
    May 20 13:03:24 b098 postfix/smtpd[21696]: disconnect from mail.gmx.net[213.165.64.20]
    May 20 13:03:25 b098 postfix/smtpd[21693]: lost connection after EHLO from 218-160-110-48.dynamic.hinet.net[218.160.110.48]
    May 20 13:03:25 b098 postfix/smtpd[21693]: disconnect from 218-160-110-48.dynamic.hinet.net[218.160.110.48]
    May 20 13:03:25 b098 postfix/smtpd[21696]: connect from 218-160-110-48.dynamic.hinet.net[218.160.110.48]
    May 20 13:03:27 b098 postfix/smtpd[21696]: warning: 218-160-110-48.dynamic.hinet.net[218.160.110.48]: SASL LOGIN authentication failed: authentication failure
    May 20 13:03:27 b098 postfix/smtpd[21696]: lost connection after AUTH from 218-160-110-48.dynamic.hinet.net[218.160.110.48]
    May 20 13:03:27 b098 postfix/smtpd[21696]: disconnect from 218-160-110-48.dynamic.hinet.net[218.160.110.48]
    May 20 13:03:30 b098 postfix/smtpd[21707]: fatal: unexpected command-line argument: =
    May 20 13:03:31 b098 amavis[20773]: (20773-06) (!) FWD via SMTP: <[email protected]> -> <[email protected]>, 450 4.4.1 Can't connect to 127.0.0.1 port 10025,  (Bad file descriptor) at (eval 42) line 145, <GEN26> line 282., MTA([127.0.0.1]:10025), id=20773-06
    May 20 13:03:31 b098 postfix/master[21635]: warning: process /usr/lib/postfix/smtpd pid 21707 exit status 1
    May 20 13:03:31 b098 postfix/master[21635]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    May 20 13:03:31 b098 amavis[20773]: (20773-06) Blocked TEMPFAIL, [213.165.64.20] [213.165.64.20] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: nu09eFLwIqBl, Hits: 0., 6622 ms
    May 20 13:03:31 b098 postfix/smtp[21702]: 68545274209: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=6.7, delays=0.06/0.01/0.01/6.6, dsn=4.4.1, status=deferred (host 127.0.0.1[127.0.0.1] said: 450 4.4.1 Can't connect to 127.0.0.1 port 10025,  (Bad file descriptor) at (eval 42) line 145, <GEN26> line 282., MTA([127.0.0.1]:10025), id=20773-06 (in reply to end of DATA command))
    May 20 13:04:30 b098 courierpop3login: Connection, ip=[::ffff:84.168.34.110]
    May 20 13:04:42 b098 courierpop3login: chdir mydomain.com/daniel/: No such file or directory
    May 20 13:06:47 b098 postfix/anvil[21697]: statistics: max connection rate 2/60s for (smtp:218.160.110.48) at May 20 13:03:25
    May 20 13:06:47 b098 postfix/anvil[21697]: statistics: max connection count 1 for (smtp:218.160.110.48) at May 20 13:03:23
    May 20 13:06:47 b098 postfix/anvil[21697]: statistics: max cache size 2 at May 20 13:03:24
    May 20 13:07:31 b098 postfix/qmgr[21637]: 39CED274211: from=<[email protected]>, size=757, nrcpt=1 (queue active)
    May 20 13:16:34 b098 courierpop3login: Connection, ip=[::ffff:84.168.34.110]
    May 20 13:16:48 b098 authdaemond: authmysql: MYSQL_USERNAME not set in /etc/courier/authmysqlrc.
    May 20 13:16:48 b098 courierpop3login: LOGIN FAILED, [email protected], ip=[::ffff:84.168.34.110]
    May 20 13:16:48 b098 courierpop3login: authentication error: Input/output error
    May 20 13:22:10 b098 postfix/master[21635]: terminating on signal 15
    May 20 13:22:12 b098 postfix/master[21844]: daemon started -- version 2.3.8, configuration /etc/postfix
    May 20 13:22:12 b098 postfix/qmgr[21846]: 39CED274211: from=<[email protected]>, size=757, nrcpt=1 (queue active)
    May 20 13:22:12 b098 postfix/qmgr[21846]: 68545274209: from=<[email protected]>, size=935, nrcpt=1 (queue active)
    May 20 13:22:12 b098 postfix/qmgr[21846]: 4B3AB274201: from=<[email protected]>, size=911, nrcpt=1 (queue active)
    
     
    Last edited: May 20, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    That can be a problem. Please save the file with Unix linebreaks (\n, not \r).
     
  3. macorama

    macorama New Member

    It's working now. I can't say for sure, what was the solution. The files are all LF and UTF-8. I've restarted all running services, must've been to do with that.

    Thanks anyways! Great tut by the way!
     

Share This Page