Postfix Virtual Users - doesnt work

Discussion in 'HOWTO-Related Questions' started by vargadanis, Aug 29, 2007.

  1. vargadanis

    vargadanis New Member

    I promise I will give as much info as I can. I followed everything according to:

    Everything seems to work.
    That is good, isn't it? I tried to send a mail to the root.
    mail [email protected]
    Subject: Test
    su - dani
    1 new mail
    That is working too. Dani is a local user that is in the /etc/aliases file. It gets the mails that are sent to root.
    So local delivery is working fine.
    I added a domain in the MySQL DB and then a user. I sent a mail to the created user but nothing happened. in the /home/vmail/ dir there should be a dir like and some more stuff, right? It is completly empty.

    I tried to log on via pop3:
    I corrected the file. It is good now

    If u need anything else, pls let me know
    Last edited: Aug 29, 2007
  2. vargadanis

    vargadanis New Member

  3. falko

    falko Super Moderator ISPConfig Developer

    Please correct this error. I guess it should be
  4. vargadanis

    vargadanis New Member

    I corrected it. However the problem still exists.
    What if I removed the computer from the internet just to test it locally. I installed bind9 on it and set up another computer to serve as NS2. So I have two NS servers on a LAN. I set up the computer to search those nameservers.
    Do u think it is a problem that that domain I wanted to test is actually not pointing to my computer and postfix was sending the emails out to the internet instead of local delivery? If it is so, than all my problems are solved.
  5. vargadanis

    vargadanis New Member

    Peeps... I am sorry... I found the solution for the problem. Actually it was there during the whole time.
    The only problem was that there was not MX pointing to my computer therefore the mail could not be delivered. So all u need to do is to edit the bind9 zone file and add and MX record. :)

Share This Page