postfix/trivial-rewrite[30414]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains

Discussion in 'HOWTO-Related Questions' started by immortalbikram, Mar 27, 2012.

  1. immortalbikram

    immortalbikram New Member

    I am facing strange problem in my ispconfig from last two days. The error log is as
    Mar 27 11:17:27 ns1 postfix/smtpd[28072]: warning: problem talking to service rewrite: Connection reset by peer
    Mar 27 11:17:27 ns1 postfix/smtpd[26710]: warning: problem talking to service rewrite: Success
    Mar 27 11:17:27 ns1 postfix/master[5274]: warning: process /usr/lib/postfix/trivial-rewrite pid 30316 exit status 1
    Mar 27 11:17:27 ns1 postfix/smtpd[29239]: warning: problem talking to service rewrite: Success
    Mar 27 11:17:27 ns1 postfix/smtpd[29120]: warning: problem talking to service rewrite: Connection reset by peer
    Mar 27 11:17:27 ns1 postfix/master[5274]: warning: process /usr/lib/postfix/trivial-rewrite pid 30317 exit status 1
    Mar 27 11:17:29 ns1 postfix/smtpd[10634]: fatal: watchdog timeout
    Mar 27 11:17:30 ns1 postfix/master[5274]: warning: process /usr/lib/postfix/smtpd pid 10634 exit status 1
    Mar 27 11:17:30 ns1 postfix/master[5274]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Mar 27 11:18:27 ns1 postfix/proxymap[26694]: warning: connect to mysql server 127.0.0.1: Lost connection to MySQL server at 'reading initial communication packet', system error: 0
    Mar 27 11:18:27 ns1 postfix/proxymap[26694]: warning: connect to mysql server 127.0.0.1: Lost connection to MySQL server at 'reading initial communication packet', system error: 0
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30414]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30415]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30416]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30417]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30418]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30419]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30420]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30421]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30422]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30423]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem

    http://pastebin.com/crUuv8kr

    Dear Falko Please help me. I am not able to send mail from my server.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which tutorial did you use to setup the server?
     
  3. immortalbikram

    immortalbikram New Member

    the server is around one year old. I have used how to forge tutorial. My machine is Ubuntu 10.04. I have forgotten the link actually what i followed.
     
  4. immortalbikram

    immortalbikram New Member

  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please restart mysql and amavis on your server.
     
  6. immortalbikram

    immortalbikram New Member

    I have restarted both services and tried rebooting the machine but not working. I am searching over the net and not able to get solution. please help me . Do you require any other log for this ?? please tell me.
    When I pgrep postfix
    I don't see any process of postfix.
    But i can see mysql
     
    Last edited: Mar 27, 2012
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    please post the output of:

    netstat -tap
     

Share This Page