Postfix TLS library problem

Discussion in 'General' started by spanish, Jun 30, 2010.

  1. spanish

    spanish Member HowtoForge Supporter

    Hello,

    I have installed OpenMeetings in my OpenVZ ISPConfig machine (server1.domain.org, 11.22.33.44). I have configured the SMTP parameters of OpenMeetings with my ISPConfig mail address ([email protected]).

    When OpenMeetings tries send an email, I get this error of Postfix:
    Code:
    Jun 30 02:55:59 servidor postfix/smtpd[10397]: connect from server1.domain.org[11.22.33.44]
    Jun 30 02:55:59 servidor postfix/smtpd[10397]: SSL_accept error from server1.domain.org[11.22.33.44]: 0
    Jun 30 02:55:59 servidor postfix/smtpd[10397]: warning: TLS library problem: 10397:error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown:s3_pkt.c:1053:SSL alert number 46:
    Jun 30 02:55:59 servidor postfix/smtpd[10397]: lost connection after STARTTLS from server1.domain.org[11.22.33.44]
    Jun 30 02:55:59 servidor postfix/smtpd[10397]: disconnect from server1.domain.org[11.22.33.44]
    # telnet localhost 25
    Code:
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 Hello friend
    ehlo localhost
    Code:
    250-server1.domain.org
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    # vi /etc/postfix/main.cf
    Code:
    ...
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    ...
    Any idea?

    Thanks,

    Manuel
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you see any errors when you created the SSL certificate?
     
  3. spanish

    spanish Member HowtoForge Supporter

    No, everything went well.
     
  4. spanish

    spanish Member HowtoForge Supporter

  5. Mark_NL

    Mark_NL New Member

    Code:
    Jun 30 02:55:59 servidor postfix/smtpd[10397]: SSL_accept error from server1.domain.org[11.22.33.44]: 0
    tells me you want to create an SSL connection, before even sending STARTTLS, so you configured the wrong secure connection in your mail client.
     
  6. spanish

    spanish Member HowtoForge Supporter

    Thanks, Mark, I will try solve this and inform here. Greetings, Manuel
     

Share This Page