Postfix tagging everything as [SPAM]

Discussion in 'HOWTO-Related Questions' started by markerman, Mar 27, 2008.

  1. markerman

    markerman New Member

    A year ago I built a mail gateway using the How To Titled "Postfix Spam Filter using Ubuntu Dapper, MailScanner, SpamAssassin, Razor, Pyzor, DCC and ClamAV" It has been working flawlessly until 3 days ago. It just started tagging all mail as [SPAM]. I was watching the log entries in mail.log using the command tail -f /var/log/mail.log. I saw every message comming thru and found an entry "MailScanner[3997]: Spam Checks: Found 1 spam messages". This is happening for messages from all senders, even those that were not being tagged before.

    What I have done already...

    White listing in sender_access then running postmap and postfix reload.

    Setting the spam level to 7 and changing the tag from [SPAM] to [SUSPECT SPAM] in the MailScanner.conf file. The subject tag did not change.

    Upgraded the change..

    Any idea's as to what happened? What else should I try?

    Thanks in advance.
  2. topdog

    topdog Active Member HowtoForge Supporter

    This could be because of ORDB just check your mailscanner config, if you are using ORDB then that may be the problem the RBL is defunct
  3. markerman

    markerman New Member

    This is whats in my MailScanner.conf file.

    Spam List = ORDB-RBL SBL+XBL

    Who should I replace ODB with? I want to use an RBL.
  4. markerman

    markerman New Member

    I set the line to "Spam List =" Did a postfix reload and nothing has changed. I think I am editing the wrong file. I also changed the subject tagging line to use [Suspect SPAM] instead os [SPAM] and that has not changed either. Subject is still tagged with [SPAM]. I am editing the one in /opt/MailScanner/etc. Hope that is the right one. Thats where the documentation says it is.
  5. Lectric

    Lectric New Member


    I experienced the EXACT same problem.

    Removing ORDB-RBL from that line has FIXED the problem.

    I am just looking for a replacement, If I get assistance to add a new RBL into the system, I would appreciate it! If I get any further advice, I will pass it along.
  6. markerman

    markerman New Member

    I make changes to the /opt/MailScanner/etc/MailScanner.conf file but they do not appear to be taking effect. I removed ORDB-RBL from that line as well and changed [SPAM] subject line tag to [Suspect SPAM] but all messages are still being tagged with [SPAM]. I rechecked the /opt/MailScanner/etc/MailScanner.conf file and my settings are still there. No ORDB-RBL and the subject tag is still set for [Suspect SPAM]. Am I editing the right file? Or is there something else I am missing? Remember, my server was setup using the How to - "Postfix Spam Filter using Ubuntu Dapper, MailScanner, SpamAssassin, Razor, Pyzor, DCC and ClamAV"
  7. Lectric

    Lectric New Member

    My 2 (two) servers that I manage were set up using the exact same thing.

    1: try running the command from #
    " check_mailscanner "

    Should restart Mailscanner and hopefully re-read the config.

    2: try restarting the mailfilter, mine only take 2-4 minutes to reboot
    " reboot " should do it, and you should find your changes work.

  8. topdog

    topdog Active Member HowtoForge Supporter

    Try /etc/MailScanner/MailScanner.conf, I use spamcop and have no issues
  9. Lectric

    Lectric New Member

    Spamcop is quite different to the method we are using.

    pico /opt/MailScanner/etc/MailScanner.conf is what i used to edit.
  10. topdog

    topdog Active Member HowtoForge Supporter

    An what method would that be ?
  11. Lectric

    Lectric New Member

    Maybe I'm mistaken, I don't recall spamcop being in the config document we used.

    I'm as newb as the next guy when it comes to linux!
  12. markerman

    markerman New Member

    edits of opt/MailScanner/etc/MailScanner.conf not working

    Tried the "check_mailscanner command", and that did not work. I rebooted the server and that worked. (At least in Windows Server 2003 you just need to restart the service. Not reboot the whole server) Thanks for all your help.

Share This Page