Postfix/STMP abruptly stopped working

Discussion in 'Server Operation' started by XMG-Eric, May 21, 2007.

  1. XMG-Eric

    XMG-Eric New Member

    Hey All,

    After hours of searching and troubleshooting with no luck, I hope someone could give me some insight to my problem.

    I have a CentOS server in which I used the "Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner..." tutorial a few months back in order to get mail working. The tutorial worked great and mail has been working flawlessly for months now. However, just a few days ago, it seems to have stopped.

    All the services are started (postfix, courier, etc...) and no configurations have been changed for months. The only actual errors I see in my maillog that I haven't seen before are the following:

    Code:
    postfix/smtpd[8348]: fatal: unsupported dictionary type: mysql
    postfix/master[8304]: warning: process /usr/libexec/postfix/smtpd pid 8348 exit status 1
    postfix/master[8304]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    postfix/cleanup[8355]: fatal: unsupported dictionary type: mysql
    postfix/qmgr[8356]: fatal: unsupported dictionary type: mysql
    postfix/master[8304]: warning: process /usr/libexec/postfix/cleanup pid 8355 exit status 1
    postfix/master[8304]: warning: /usr/libexec/postfix/cleanup: bad command startup -- throttling
    postfix/master[8304]: warning: process /usr/libexec/postfix/qmgr pid 8356 exit status 1
    
    Any help would be much appreciated.

    Thanks!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    means that there's no MySQL support in your Postfix. You must compile it in.
     
  3. XMG-Eric

    XMG-Eric New Member

    Thanks fo the reply. I've re-compiled it with mysql support and since, the previous error is gone, however, I can now recieve mail fine, but SMTP authentication is not working, with the following error:

    Code:
    warning: SASL PLAIN authentication failed
    warning: SASL LOGIN authentication failed
    
    My email client just keeps asking for the password, in which, it fails to authenticate everytime.

    Any Ideas?

    Thanks again.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /usr/lib/sasl2/smtpd.conf?
     
  5. XMG-Eric

    XMG-Eric New Member

    Code:
    # smtpd.conf
    pwcheck_method: authdaemond
    log_level: 3
    mech_list: PLAIN LOGIN
    authdaemond_path:/usr/local/var/spool/authdaemon/socket
    Thanks
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Are you absolutely sure you provided the correct username and password?
     
  7. XMG-Eric

    XMG-Eric New Member

    Alright, when I attempted to check it again this morning mysql support has disappeared again! How could this be happening? It seems as though yum installed it's version of postfix (which does not have mysql support) over my version, which I compiled from source. No one has logged in the server to do this nor does any irregular activity show up in any logs. In the mail log mail is being received fine then this error comes back:

    Code:
    fatal: unsupported dictionary type: mysql
    I've really never seen anything like this before? Is yum doing some kind of automatic updates?

    Thanks
     
    Last edited: May 27, 2007
  8. falko

    falko Super Moderator ISPConfig Developer

    I guess you have automatic updates turned on. Can you check your cron jobs?
     
  9. XMG-Eric

    XMG-Eric New Member

    Yeah, found and disabled it, didn't think to check there. Thanks!

    However, still can't get postfix going, with the same "login failed" errors.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Have you recompiled Postfix with MySQL support after you've turned off the automatic updates?
     
  11. XMG-Eric

    XMG-Eric New Member

    Yeah, When i recompile postfix from the source, I receive an "unsupported protocol: cyrus" in my mail log. And when I compile Postfix through a Postfix-MySQL RPM I've found I receive the "Login Failed" Error.

    Also, i tried the "yum install --enablerepo=centosplus postfix" line mentioned in the tutorial again (as it worked for me when I first setup my mail server). But it doesn't include mysql support any longer. Any ideas why that is?

    Thanks again,
    - Eric
     
  12. space007

    space007 New Member

    HOWTO outdated

    I would like to know that one too. cost me lots of time :(


    Anyway, thanks for the good detailed howto. Unfortunately is from 2007 ..



    Code:
    # cat /etc/redhat-release
    CentOS release 5.2 (Final)
    same problem here, no mysql in the postfix package from "CentOS-5 - Plus"

    The HOWTO should be updated in warning the reader that its no longer apply for the current build.

    maybe an alternative route/addon of the howto to manually compile postfix with mysql support would be in order. unfortunately I don't have the skills for that.

    Rgrds
     
  13. space007

    space007 New Member

    I believe that the correct package for postfix package name for i386 is:

    postfix-2.3.3-2.el5.centos.mysql_pgsql.i386.rpm
     

Share This Page