postfix/smtpd[2659]: fatal: no SASL authentication mechanisms

Discussion in 'Installation/Configuration' started by Wisdown, Aug 26, 2012.

  1. Wisdown

    Wisdown Member

    Checking the Log from mail i noticed this error and dont know how to fix it:

    Code:
    Aug 25 20:16:46 server amavis[2474]: (02474-01) (!)FWD via SMTP: -> , 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 101) line 596, line 29.): id=02474-01
    Aug 25 20:16:48 server amavis[2475]: (02475-02) (!)FWD via SMTP: -> , 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Error writing to socket: Broken pipe at (eval 101) line 200, line 42.): id=02475-02
    Aug 25 21:01:32 server dovecot: dovecot: Killed with signal 15 (by pid=3688 uid=0 code=kill)
    Aug 25 21:02:28 server postfix/smtpd[2652]: warning: SASL: Connect to private/auth failed: No such file or directory
    Aug 25 21:02:28 server postfix/smtpd[2652]: fatal: no SASL authentication mechanisms
    Aug 25 21:02:29 server postfix/master[2621]: warning: process /usr/lib/postfix/smtpd pid 2652 exit status 1
    Aug 25 21:02:29 server postfix/master[2621]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Aug 25 21:02:29 server amavis[2502]: (02502-01) (!)FWD via SMTP: -> , 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 101) line 596, line 21.): id=02502-01
    Aug 25 21:40:26 server dovecot: dovecot: Killed with signal 15 (by pid=6023 uid=0 code=kill)
    Aug 25 21:41:26 server postfix/smtpd[2659]: warning: SASL: Connect to private/auth failed: No such file or directory
    Aug 25 21:41:26 server postfix/smtpd[2659]: fatal: no SASL authentication mechanisms
    Aug 25 21:41:27 server postfix/master[2628]: warning: process /usr/lib/postfix/smtpd pid 2659 exit status 1
    Aug 25 21:41:27 server postfix/master[2628]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Aug 25 21:41:27 server amavis[2485]: (02485-01) (!)FWD via SMTP: -> , 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 101) line 596, line 21.): id=02485-01
    I did:

    apt-get -y install sasl2-bin

    Then i set

    START=yes
    /etc/default/saslauthd

    And the problem persist.

    The i followed this guide:

    http://www.howtoforge.com/postfix-d...private-auth-failed-no-such-file-or-directory

    But no luck, any hint please?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which linux distribution do you use?
     
  3. Wisdown

    Wisdown Member

    I`m using Debian 6
     
  4. Wisdown

    Wisdown Member

    Hey,

    Instead continue the try to fix this issue on the other post:

    http://www.howtoforge.com/forums/showthread.php?t=58453

    I back to this one for people can find the solution fast because the topic name.
    I fixed this error:


    In a new fresh installation trying again the multiple servers setup, after log as root before install anything on mail server i did:

    apt-get remove libsasl2-2

    Then i followed the entire guide and worked without SASL erros.

    Now i`m trying to enable the disabled things, got 3 working after read this topic:

    http://www.howtoforge.com/forums/showthread.php?t=5046

    Now i`m focusing on fix those things:

    I have no idea what those messages means, but this one:

    OS_Fingerprint code NOT loaded

    I guess is because my host (I`m using debian as mailserver inside of vmware) have an fingerprint reader, so debian would have detected it and is missing an setup, if is it i will ignore this message and search how to fix the other ones

    Note: Removing libsasl2-2, the ISPConfig show me more stuff on install, so my guess is the setup look for libsas and if found try setup the things in an way, if not find he set the things for dovecot, i dindt read the installer script, just guessing.
    As more stuff i get for example:
    Setting Mailman (I dont have mailman because i dont wanna 2 apache - 1 on webserver / 1 mailserver - and dindt found an guide to use mailman out of mailserver) - This never poped before ...

    And now seems dovecot is ok:

    netstat -tap | grep pop

    But on this the result still strange:

    netstat -tap | grep smtp

    Is normal show 2496/master or should be 2496/postfix?
     
    Last edited: Sep 3, 2012
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The smtp output is fine, the postfix smtp process is named master and not postfix.
     
  6. Wisdown

    Wisdown Member

    On 4th day of researches, i got some help on experts exchange for some of those erros, i will update my findings, but this part is very fun:

    The lack of knowledge make me say this shit, lmao, cant beliviet...
    I discovered the OS fingerprint is an app to detect the OS runing in an IP

    To enable this with default packages:

    Add

    Note: Not sure if is to be localhost (127.0.0.1) or your LAN IP (192.168.*.* or 10.0..*.*), i`m using localhost since i saw this way on net, if someone know the right please to use here, please speak

    restart the service an check the log, will be loaded.

    or you can use (replacing the old ones) the lastest version (out of the repo thanks for noci on expertsexchange)

    http://lcamtuf.coredump.cx/p0f3/

    Enabling the filters (thanks for michele on http://www.howtoforge.com/forums/showthread.php?t=5046 )


    ANTI-VIRUS
    ANTI-SPAM
    ANTI-SPAM-SA


    ANTI-SPAM-EXT code NOT loaded
    ANTI-SPAM-C code NOT loaded

    "is the use of the spamc program of spamassassin if spamassassin is on a remote system"
    Once more time thanks for noci on experts exchange, i dont gonna use spamassassin in a remote system, so now i can relax about this message, since i got the description what this means...


    BSMTP-out proto code NOT loaded

    "is a module that tries to deliver mail directly and if it fails it writes the mail to a file. If the mail does get deliverd all pending mails from the file are sent too.
    [ For the use by dialup users that want an SMTP feed in stead of POP/IMAP ]"
    Once more time thanks for noci on experts exchange, seems i dont gonna need, still dont got how this work, but seems useless to me, ignoring now too.


    Pipe-out proto code NOT loaded

    Seems is an way to make the mail verification more fast, passing 2 way instead 3, using pipes, seems need a lot of work to setup it, and i dont think this worth the efforts (for me as user) since change lot of defaults files (worring about an update of ISPConfig change those files too).


    Lookup::LDAP code NOT loaded

    Seems this is for LDAP authentication protocol, i dont will need it, ignoring too.

    DKIM code NOT loaded

    http://www.faqforge.com/linux/how-to-enable-dkim-email-signatures-in-amavisd-new-and-ispconfig-3/
    Working pretty nice


    The next messages i still without info about, gonna research more about those, if someone know what mean and can explain, or show how to fix, i gonna be very gratefull

    SQL::Quarantine NOT loaded
    Tools code NOT loaded
    Group Not Defined. Defaulting to EGID '113 113'
    mail amavis[2435]: Net::Server: User Not Defined. Defaulting to EUID '108'
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The NOT LOaded messages are no errors, so they are nothing to be fixed. These are just functions that are not used or not required on a ispconfig server or that are optional like dkim.

    Regarding the filters that you enabled manually, they are normally enabled in ispconfig mail module, so you dont have to edit any config files for that and you manual changes will get overridden anyway by the settings of the interface.
     

Share This Page