1. I am running Ubuntu Dapper 6.06 LTS (setup: The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake))

    POP3 authentication works just fine, but I am unable to send.
    Any advice?!

    Cheers

    Mar 17 10:35:06 MyHost postfix/smtpd[15795]: connect from unknown[192.168.1.141]
    Mar 17 10:35:06 MyHost postfix/smtpd[15795]: setting up TLS connection from unknown[192.168.1.141]
    Mar 17 10:35:06 MyHost postfix/smtpd[15795]: TLS connection established from unknown[192.168.1.141]: TLSv1 with cipher RC4-MD5 (128/128 bits)
    Mar 17 10:35:08 MyHost postfix/smtpd[15795]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Mar 17 10:35:08 MyHost postfix/smtpd[15795]: warning: unknown[192.168.1.141]: SASL LOGIN authentication failed
    Mar 17 10:35:11 MyHost postfix/smtpd[15795]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Mar 17 10:35:11 MyHost postfix/smtpd[15795]: warning: unknown[192.168.1.141]: SASL LOGIN authentication failed
    Mar 17 10:35:13 MyHost postfix/smtpd[15795]: disconnect from unknown[192.168.1.141]
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to run:

    /etc/init.d/saslauthd start
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ps aux|grep saslauthd
    ? What's in /etc/default/saslauthd and /etc/init.d/saslauthd?
     
  4. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    i have had the same problem.
    please be sure, that the STARTING directory ( defined in /etc/default/saslauth)
    exists.

    in MY case i have to set the OPTIONS= and not (like you can read in the howto) PARAMS=...

    please have a look at this file and try OPTIONS=

    ATTENTION: i have debian, maybe it is different to yours!
     
  5. /etc/default/saslauthd

    'K ... I am think I am getting somewhere here:

    # This needs to be uncommented before saslauthd will be run automatically
    START=yes

    # You must specify the authentication mechanisms you wish to use.
    # This defaults to "pam" for PAM support, but may also include
    # "shadow" or "sasldb", like this:
    # MECHANISMS="pam shadow"

    MECHANISMS="pam"

    I uncommented the line above and now ps aux|grep saslauthd reports:

    root 13601 0.0 0.1 6020 988 ? Ss 11:17 0:00 /usr/sbin/saslauthd -a pam
    root 13602 0.0 0.1 6020 588 ? S 11:17 0:00 /usr/sbin/saslauthd -a pam
    root 13603 0.0 0.1 6020 536 ? S 11:17 0:00 /usr/sbin/saslauthd -a pam
    root 13604 0.0 0.1 6020 536 ? S 11:17 0:00 /usr/sbin/saslauthd -a pam
    root 13605 0.0 0.1 6020 536 ? S 11:17 0:00 /usr/sbin/saslauthd -a pam
    root 19787 0.0 0.1 2880 796 pts/1 R+ 18:38 0:00 grep saslauthd

    ... but I am still getting the same error!

    What's next?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Take a look at http://www.howtoforge.com/perfect_setup_ubuntu_6.06_p5 :

    Seems you left that step out.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of the telnet command. To quit it, type "quit" and hit return.
     
  8. Fixed!

    Sorry, I wasn't clear in my last post. The culprit was:
    /etc/default/saslauthd:

    # This needs to be uncommented before saslauthd will be run automatically
    START=yes

    PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"


    # You must specify the authentication mechanisms you wish to use.
    # This defaults to "pam" for PAM support, but may also include
    # "shadow" or "sasldb", like this:
    # MECHANISMS="pam shadow"

    MECHANISMS="pam"

    What I meant to say in my last post was that I did set this up before, because I do remember testing the config and I got:

    250-STARTTLS
    and
    250-AUTH

    So it's a bit of mystery to me what happened, but if this comes up again I will take notes and post a follow up.

    Thanks again!

    Cheers
     

Share This Page