Postfix/SMTP Beginner Problem

Discussion in 'Installation/Configuration' started by rannday, Mar 9, 2013.

  1. rannday

    rannday New Member

    I'm able to send/receive emails locally, but not externally. All the required ports are open on my home router. Attached are my current firewall rules,, mail.log - tail end of it, and my godaddy zone file. My server was set up following

    Everything went smoothly, but I just don't completely understand what I'm doing wrong with postfix and/or smtp. I'm unable to telnet outside of my LAN, and when I went here

    and ran the blacklist check, two websites have me blacklisted, even though I've never had the website going until now. The SMTP check failed as well.

    I added the results of lsof -i -n -P. I have some netstat runs as well, if need be. I could also install nmap and run that. It would probably be best to run all of these from a different computer, though. I'll also run them on my router. Will take a minute.

    Attached Files:

    Last edited: Mar 9, 2013
  2. rannday

    rannday New Member

    More Information

    I ran some more scans. Two were intensive zenmap scans from another host to my server and gateway. The other is a nmap scan through a proxy to my IP.

    I did a scan from and the results are much different.

    21 Open
    22 Open
    25 smtp Thread was being aborted.
    53 Open
    80 http Thread was being aborted.
    110 Open
    143 Open
    443 https No connection could be made because the target machine actively refused it xx.xx.xx.xx:443

    So perhaps it's a firewall issue. I'll try opening those up and see what happens.

    Attached Files:

    Last edited: Mar 9, 2013
  3. rannday

    rannday New Member

    Think I Got It Working

    Not sure which setting it was. First I tried
    iptables -P OUTPUT ACCEPT
    And tried and thought it didn't work. I then looked up the relay for Cox Communications, which is, added that to my There weren't any errors in my mail.log so I checked the email I sent it it to and had two test emails in there. Now I'll try to receive.

Share This Page