Postfix SMTP Authorization Problems?

Discussion in 'Server Operation' started by matto1376, Dec 11, 2007.

  1. matto1376

    matto1376 New Member

    Hi Guys

    I am having an SMTP autentication problem....
    My system was working until a bad power failure the other day and since then I have not been able to send mail.

    It was configured to use port 587 for sending.

    Now, it just prompts me for a username and password, but won't accept them.

    I know this will be simple for someone....sorry!

    Here is my netstat -tap :
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
    tcp        0      0 *:imaps                     *:*                         LISTEN      2009/xinetd         
    tcp        0      0 *:pop3s                     *:*                         LISTEN      2009/xinetd         
    tcp        0      0 *:5801                      *:*                         LISTEN      1897/Xvnc           
    tcp        0      0 *:mysql                     *:*                         LISTEN      1964/mysqld         
    tcp        0      0 *:submission                *:*                         LIST
    EN      27952/master        
    tcp        0      0 *:5901                      *:*                         LISTEN      1897/Xvnc           
    tcp        0      0 *:pop3                      *:*                         LISTEN      2009/xinetd         
    tcp        0      0 *:imap                      *:*                         LISTEN      2009/xinetd         
    tcp        0      0 *:81                        *:*                         LISTEN      813/ispconfig_httpd 
    tcp        0      0 *:6001                      *:*                         LISTEN      1897/Xvnc           
    tcp        0      0 *:ftp                       *:*                         LISTEN      3361/proftpd: (acce 
    tcp        0      0 192.168.0.101:domain        *:*                         LISTEN      1067/named          
    tcp        0      0 apatula:domain              *:*                         LISTEN      1067/named          
    tcp        0      0 localhost:domain            *:*                         LISTEN      1067/named          
    tcp        0      0 *:smtp                      *:*                         LISTEN      27952/master        
    tcp        0      0 localhost:rndc              *:*                         LISTEN      1067/named          
    tcp        0   4154 apatula:5901                58.107.8.240:57559          ESTABLISHED 1897/Xvnc           
    tcp        0      0 *:http                      *:*                         LIST
    EN      966/httpd           
    tcp        0      0 *:6001                      *:*                         LISTEN      1897/Xvnc           
    tcp        0      0 ::1:rndc                    *:*                         LISTEN      1067/named          
    tcp        0      0 *:https                     *:*                         LISTEN      966/httpd    
    Here is my master.cf:
    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the Postfix master(5) manual page.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    
    smtp      inet  n       -       n       -       -       smtpd
    submission inet n      -       -       -       -       smtpd
    
      -o smtpd_etrn_restrictions=reject
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps    inet  n       -       n       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    # submission   inet    n       -       n       -       -       smtpd
    # -o smtpd_etrn_restrictions=reject
    # -o smtpd_enforce_tls=yes 
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_use_tls=yes
    # -o smtpd_rcipient_restrictions=permit_sasl_authenticated,reject 
    #628      inet  n       -       n       -       -       qmqpd
    pickup    fifo  n       -       n       60      1       pickup
    cleanup   unix  n       -       n       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       n       300     1       oqmgr
    tlsmgr    unix  -       -       n       1000?   1       tlsmgr
    rewrite   unix  -       -       n       -       -       trivial-rewrite
    bounce    unix  -       -       n       -       0       bounce
    defer     unix  -       -       n       -       0       bounce
    trace     unix  -       -       n       -       0       bounce
    verify    unix  -       -       n       -       1       verify
    flush     unix  n       -       n       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       n       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       n       -       -       smtp
    	-o fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       n       -       -       showq
    error     unix  -       -       n       -       -       error
    discard   unix  -       -       n       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       n       -       -       lmtp
    anvil     unix  -       -       n       -       1       anvil
    scache	  unix	-	-	n	-	1	scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
    #
    # The Cyrus deliver program has changed incompatibly, multiple times.
    #
    old-cyrus unix  -       n       n       -       -       pipe
      flags=R user=cyrus argv=/usr/lib/cyrus-imapd/deliver -e -m ${extension} ${user}
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    cyrus     unix  -       n       n       -       -       pipe
      user=cyrus argv=/usr/lib/cyrus-imapd/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
    Any ideas guys?? Bearing in mind I do need this to run off port 587??

    Thank you!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using? Any errors in your logs?
     
  3. matto1376

    matto1376 New Member

    Distribution info

    Hi falko, thanks for responding, there is more info on another post, sorry I didn't see your reply, but you can see what happens if I telnet also.

    I have Fedora 4, and followed the Perfect Setup.

    The Perfect Setup worked perfectly until my ISP blocked port 25, then I set it up for port 587 after reading posts here.

    That worked fine until this latest fiasco.

    As for logs, I'm not a Fedora guru, but I can't actually find a log to know logging is working. I have looked in the places outlined in some posts, but can't turn anything up.

    Any hints there??

    Thanks.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is SELinux disabled?
    Take a look at /var/log/maillog.
     
  5. matto1376

    matto1376 New Member

    No luck....

    Hi Falko

    I don't think SELinux is running, there is an SElinus folder, but it has nothing in it.

    There is also nothing in the maillog files in var/log

    This is a mystery!! It was working fine until a week ago....it still recieves ok, just can't send when I am out of my local area network.
    It just throws up the authenication box at me.

    Any other ideas??
    Thank You!
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Does your mail client show an error message? Are you using your router's public IP address to connect or a hostname? If a hostname, does it point to your router'S public IP address?
    Does your router forward port 587 to the mailserver? Does your ISP block port 587?
     
  7. matto1376

    matto1376 New Member

    Crisis Over

    OK here is what happened, I feel dumb right now.....but anyway...

    My ISP had changed their DNS server, (DNS is the only thing I don't run locally)

    So of course, the server had no idea where anything was apart from what was on my LAN.

    Changed the DNS to their new server and away it goes.

    Moral to the story, make sure you have a properly working network connection first up!!

    Thanks Falco for the prompting, sorry for wasting anyones time reading this!!



    :)
     

Share This Page