Postfix smtp authentication

Discussion in 'Installation/Configuration' started by MadEgg, Oct 25, 2009.

  1. MadEgg

    MadEgg New Member


    I have ISPConfig 3 on a Ubuntu 8.04 LTS server and it all seems to work quite allright but now I run into a problem regarding postfix/smtp relay.

    I would like to be able to use the server as an SMTP server that can relay mail to other mail servers. Of course I do not want an open relay so I would like to use authentication.

    The problem is: when I specify no username and password, I get a message 'Relay not accepted' which seems fine, but when I do specify a username and password it does not accept it.

    Is this functionality set up by default or do I need to change anything in the configuration? And what username/password should I use anyway? The client username/password for accessing the ISPConfig interface or a mailboxname, and if the latter, with or without the domain?

    So, lets say my account in the ISPconfig interface is tvdwal, my email address is [email protected], which should I use?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You use the email address and mailbox password, the same that you use for pop3 and imap. Just make sure that you enable smtp authentication in your email client and not SSL.
  3. MadEgg

    MadEgg New Member

    No SSL? The 'Perfect Server Guide' is all over 'postfix with TLS' this and that, so why should I disable security?

    Anyway, I tried disabling secure connections and enabled authentication using my IMAP username and password, still refuses... Any clues on what I should check?
  4. MadEgg

    MadEgg New Member

    Right, stupid. I checked /var/log/mail, and found these error messages:

    warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    warning:[]: SASL LOGIN authentication failed: generic failure

    The problem was that saslauthd was not started; the cause for this was that /etc/init.d/saslauthd script was not set executable. After I did this and added it to default runlevels, I could start saslauthd and now it works, including TLS. Thanks for the help!

Share This Page