Postfix - SMTP - authentication failed

Discussion in 'Server Operation' started by Hans, Mar 31, 2006.

  1. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    I use my Postfix smtp-server for outgoing email.

    Since today; when i send an email using my emailclient and this Postfix SMTP-server, an error occurs:

    Authentication failed:
    The username and/or password is not permitted.

    I also discovered that i can not start the saslauthd daemon:
    /etc/init.d/saslauthd start

    When i do an /etc/init.d/saslauthd start

    I receive this message:
    Starting SASL Authentication Daemon: (failed).

    What can be wrong?

    I hope someone knows.


    Hans
     
    Last edited: Mar 31, 2006
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please have a look at your mail log and post the errors here.
     
  3. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    A piece of my mail log:

    Mar 31 19:03:19 server1 postfix/smtpd[17383]: TLS connection established from MYHOSTNAME[MYIPADDRESS]: TL$
    Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2:$
    Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2:$
    Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: SASL authentication failure: no secret in database
    Mar 31 19:03:19 server1 postfix/smtpd[17383]: warning: MYHOSTNAME[MYIPADDRESS]: SASL CRAM-MD5 authenticat$
    Mar 31 19:03:19 server1 postfix/smtpd[17383]: disconnect from MYHOSTNAME[MYIPADDRESS]

    Hans
     
    Last edited: Apr 1, 2006
  4. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

  5. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    saslauthd problems continue

    I thought that i solved the problem.
    But the problem still remains.

    When i kill all processes as mentioned in Falko's solution,
    saslauthd is is starting up indeed, but when i give the command:

    /etc/init.d/saslauthd restart

    The system responds:

    Stopping SASL Authentication Daemon: (not running).
    Starting SASL Authentication Daemon: (failed).

    So, my conclusion is: saslauthd is not running at all and maybe it also explains a bit my problem with authentication using smtp, as descibed in thread called "Can not receive e-mail - Postfix" from yesterday.

    I do not know what to do now,

    Some support would be great!


    Hans
     

Share This Page