Postfix-SMTP-AUTH-TLS-Howto install errors (pfixtls.diff patch)

Discussion in 'HOWTO-Related Questions' started by jjw, Sep 6, 2006.

  1. jjw

    jjw New Member

    Thank you in advance for you reading this and hoepfully helping me.

    Using Core 4, I am attempting the Postfix-SMTP-AUTH-TLS-Howto "how to". I've had to search for other sources (as I get this message when attempting to get anything from ftp.aet.tu-cottbus.de: Resolving ftp.aet.tu-cottbus.de... failed: Host not found.). Also, some packages are not available so I am getting the nearest source I can find. I've settled on these:

    wget http://www.openssl.org/source/openssl-0.9.7c.tar.gz
    wget --passive-ftp ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-2.1.22.tar.gz
    wget --passive-ftp ftp://mirrors.loonybin.net/pub/postfix/official/postfix-2.0.20.tar.gz
    wget --passive-ftp ftp://mirrors.loonybin.net/pub/postfix_tls/pfixtls-0.8.18-2.1.3-0.9.7d.tar.gz


    Now, I've made it through the unpacking/config/make/make install for openssal and cyrus-sasl. The next part is yielding error messages:

    yields:
    What should I do?
     
  2. jjw

    jjw New Member

    Thinking that perhaps I should adjust the diff file, I replaced the older version suggested in the diff file with the current version of postfix that I have source for:
    # sed -e "s/postfix-2.1.3/postfix-2.0.20/g" pfixtls.diff > pfixtls-new.diff
    And then I ran:
    # patch -p1 < ../pfixtls-0.8.18-2.1.3-0.9.7d/pfixtls-new.diff
    The output:
    Is it perhaps that this version of postfix already is patched correctly?
     
  3. jjw

    jjw New Member

    Well, I tried using the how to without the patch, and I go this:

    Clearly, I am not getting the required output of:
    [​IMG]

    Sigh.
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. jjw

    jjw New Member

  6. jjw

    jjw New Member

    Your Server Does Not Support Secure Authentication

    I made it all the way through the install, added dovecot (1.0) so I can retrieve email. Sent emails from command line, and I can access the box from command line vi pop. However, and this is the bibbie, I still can't authenticate smtp. I can get mail using SSL/TLS, but it will not authenticate.

    I am at wit's end here...
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when you try to send mails? What's the error message in your email client?
    What's the output of
    Code:
    telnet localhost 25
    and then
    Code:
    ehlo localhost
    ?
     
  8. jjw

    jjw New Member

    Thank you Falko.

    The message in the mail client:
    "Mail server does not support secure authentication."

    Nothing at all is appended to maillog when I attempt secure authentication & TLS.

    This single line is appended to the dovecot log when I attempt secure authentication with TLS:
    Code:
    dovecot: Sep 08 14:08:44 Info: pop3-login: Disconnected: rip=192.168.0.13, lip=192.168.0.10, TLS
    When I attempt secure authentication without TLS, nothing is appended to either maillog or dovecot logs.:confused:

    Code:
    #> telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 mail.wnetworks.net ESMTP Postfix
    Code:
    ehlo localhost
    250-mail.wnetworks.net
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN DIGEST-MD5 PLAIN CRAM-MD5
    250-AUTH=LOGIN DIGEST-MD5 PLAIN CRAM-MD5
    250-XVERP
    250 8BITMIME
    Thanks for taking the time Falko.

    Joe
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Dovecot is for fetching emails, not for sending.

    Are you sure you're using the correct server in your email client settings? Have you tried the server's IP address in your email client settings to rule out DNS problems?
     
  10. jjw

    jjw New Member


    I just attempted this using the boxes IP address, with the same results.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Might be a firewall problem then. What's the output of
    Code:
    iptables -L
    and
    Code:
    netstat -tap
    ?
     
  12. jjw

    jjw New Member

    /sbin/iptables -L
    Code:
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    netstat -tap:
    Code:
    tcp        0      0 *:imaps                     *:*                         LISTEN      3848/dovecot
    tcp        0      0 *:32769                     *:*                         LISTEN      1615/rpc.statd
    tcp        0      0 *:pop3s                     *:*                         LISTEN      3848/dovecot
    tcp        0      0 *:pop3                      *:*                         LISTEN      3848/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      3848/dovecot
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1597/portmap
    tcp        0      0 *:smtps                     *:*                         LISTEN      3106/master
    tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      1991/cupsd
    tcp        0      0 localhost.localdomain:5335  *:*                         LISTEN      1973/mDNSResponder
    tcp        0      0 *:smtp                      *:*                         LISTEN      3106/master
    
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Is the server in your local network? If so, did you try its local IP address, or the router's public one? Maybe your ISP is blocking port 25.
     
  14. jjw

    jjw New Member


    The machine is on my local LAN. I have 4 linux boxes, one of wich is running a mail server based on Surgemail (but I really want to migrate to postfix), and has been for three years. No, port 25 is not blocked. I have DNS on the LAN that points correctly to the IP of the server I am trying to set up, and it doesn't matter whether I use the local IP or the name of the server in the mail client (I get the same result).

    When I try the public IP, I am taken to the existing mail server (port 25 points to it) instead of the one I am trying to configure. Incoming mail to the domains I have set up on the server I am trying to configure is relayed to it by the server (surgemail) that receives incoming port 25 traffic.

    Thanks for taking the time to read and respond Falko.

    Joe
     

Share This Page