Postfix, smtp auth problems

Discussion in 'HOWTO-Related Questions' started by fish, Sep 19, 2007.

  1. fish

    fish New Member

    I have an Ubuntu 6.06 setup using the perfect setup created by falko. I followed all the steps for smtp auth, but still cannot get the system working properly. While I can send and receive mail from my desktop (right beside the server) my outside users (outside my four walls) cannot. I have gone through many of the discussions on this forum, but have done all the stuff that they suggest. I am in real need of someone who could walk me through some diagnostic stuff to find out where the problem is and how to fix it.
     
  2. chuckl

    chuckl New Member

    What causes you to believe that they should be able to send and receive mail using your server?
    i.e. Is your server part of a registered domain? Is there a domain MX record pointing at your server, and a DNS entry for the server itself? If you go to www.dnsstuff.com and do a DNS Report, on the domain does it give a clean bill of health? If there is a router and the internet between your outside users and the server, is it configured to forward the necessary ports to the server?
     
  3. fish

    fish New Member

    I have several domains, a couple of which have dns entries and mx records pointing at my server. DNSstuff does have a problem with my main domain because my email is routed through an external spam filter, but that doesn't affect any other email account on my server except my personal one. Everything is configured to allow users through (as far as I know). Up until two weeks ago, the user in question could send and receive mail. I did an update (using update manager) and then found out a couple of days later that he could no longer retrieve his mail from outside. He has no problem sending mail, but could not get his mail. This is not true when we use his account on this (internal network) side of the cable modem. As far as I could tell, there were no configuration changes as a result of the update. As I have already stated, I checked the various config files against the examples in the perfect setup. Another user (now on a trip so I can't get him to test the system) cannot send, but can retrieve. I am stumped.
     
  4. chuckl

    chuckl New Member

    So you have internet-cable modem-local network-server.

    On the internet somewhere you need a nameserver with a DNS entry pointing to the external IP of your cable modem for the server machine. You also need an MX record pointing to the same place for the domain(s) that use it as a mail server.

    The cable modem needs to forward port 25 and 110 traffic to the server.

    The server needs to accept the connections and the logons.

    One or more of those is not in place.
     
  5. fish

    fish New Member

    All of those are in place. My primary domain for internet and mx is livingsky.net (there are several virtual domains on the same server), and all ports are working just fine, I get and send mail without a problem. My nameservers are both external (whatevercomputes.com) and internal (livingsky.net). Mail traffic is constant and generally experiences no problem for internal users, just for the external ones.
     
  6. chuckl

    chuckl New Member

    Then the problem reduces to - either the external clients cannot find or connect to your system, they are being blocked by a router firewall or similar software on the server, or they do not have the necessary permissions.
    What error messages do they get when trying to connect?
     
  7. fish

    fish New Member

    Thanks for your reply. I am actually having to leave for the weekend and will respond to you on Monday or later. I really appreciate your help and do want to figure this out.
     
  8. fish

    fish New Member

    Thank you for being patient.

    Ok, I did some work on it. Where I am at now is that my external user who was having the problems, can now send and receive, (using mynetworks in /etc/postfix/main.cf) so I can relax a little, but not much.

    External users can still not send or receive, internal users can. I have tried (using mailman, the only external I can control) sending mail through one of the lists but keep getting the message that there is no user/mailbox by that name. When I try sending to the same list internally, it works no problem. As far as I can tell, saslauthd is working, ssl is not, but I am not sure why, since I followed the instructions point by point (cut-and-paste) in the setup designed by falko.
     
  9. fish

    fish New Member

    smtp auth problems


    Sorry, I forgot to put this in my previous reply. I do not see any error messages when trying to send mail, in fact, I see nothing, no listed attempt to send or relay mail, no connection information, nothing.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Are you connecting to the correct server? Is there maybe a firewall blocking port 25? If you're hosting your server at home, make sure that your ISP doesn't block port 25.
     

Share This Page