Postfix SMTP Auth no works

Discussion in 'Server Operation' started by abailarri, Mar 21, 2014.

  1. abailarri

    abailarri New Member

    Hello

    I followed this guide to make my postfix works with smtp auth:
    http://www.howtoforge.com/postfix-smtp-authentication-on-the-secure-port-only

    I followeb step by step, but when I make telnet localhost 465, instead this:

    [[email protected] postfix]# telnet localhost 465
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 yourserver ESMTP Postfix
    ehlo me
    250-yourserver
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    AUTH PLAIN Y2FtZXJvbnMAY2FtZXJvbnMAdGVzdGluZzA4
    235 2.0.0 Authentication successful

    I see this:

    Trying ::1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 myserver.net ESMTP Postfix (Debian/GNU)
    ehlo me
    250-myserver.net
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH DIGEST-MD5 NTLM CRAM-MD5 LOGIN PLAIN
    250-AUTH=DIGEST-MD5 NTLM CRAM-MD5 LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN

    There is not the last lines:

    AUTH PLAIN Y2FtZXJvbnMAY2FtZXJvbnMAdGVzdGluZzA4
    235 2.0.0 Authentication successful

    Any help please?
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Post the error message(s) that you get in the mail log file when the problem occurs. The mail log file is in the folder /var/log/, it is named "mail.log" on Debian and Ubuntu Linux and named "maillog" on other distributions.


    Br//
    Srijan
     
  3. abailarri

    abailarri New Member

    Hello

    I looked the logs and all are empty. I can see the error when I try to configure Thunderbird with some account. When I want to send email I see this error: Failed sending the message.
    An error occurred sending mail: it is not possible to establish a secure link with SMTP server using STARTTLS mail.mydomain.com since he claims to have that feature. Try turning off STARTTLS for that server or contact your service provider. Then, I don't know is a thunderbird configuration error or postifx configuration error.
     
  4. srijan

    srijan New Member HowtoForge Supporter

    These error seems to be of thunderbird, I will recommend to check it with any other mail-client. May be Evolution will be a good alternate for that.

    Br//
    Srijan
     

Share This Page