Postfix SMTP-AUTH Issue

Discussion in 'HOWTO-Related Questions' started by max0r, May 9, 2008.

  1. max0r

    max0r New Member

    Postfix SMTP-AUTH Issue - Solved!

    I followed the tutorial called “Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)”. I did it on Fedora 8.

    Everything went fine, with one or two minor issues that I solve quickly; except one annoying problem that I have no idea how to solve it.

    The problem is that only the first account ever created, for each virtual e-mail domain, is capable of using the SMTP-AUTH feature, the next added account keeps asking for password, and the “maillog” shows:

    Code:
    -May  9 11:12:28 punk postfix/smtpd[29706]: warning: unknown[192.168.111.254]: SASL LOGIN authentication failed  “(Obs: The password is correct, I’ve checked that, in IMAP, for example)”
    
    -May  9 11:12:28 punk postfix/smtpd[29706]: lost connection after AUTH from unknown[192.168.111.254]
    
    In "messages" log file:

    Code:
    May  9 17:00:31 punk saslauthd[2497]: do_auth         : auth failure: [user=<username>(without realm)] [service=smtp] [realm=<realmname>] [mech=pam] [reason=PAM auth error]
    With “My Outgoing server (SMTP) requires authentication” (@ Outlook) turned off, the sending is automatically rejected, as expected.

    With all the first accounts ever created, per domain, everything works fine (with internal and external delivers).

    EDIT: Only the first account ever added works. The others, with no visible reason, where using the username/password of that account for smtp-auth, when sending e-mails. They dont work with their credentials.

    Does Postfix/SMTP-AUTH has some kind of "Max Connections" per IP protection?

    Thanks in Advance! :)
     
    Last edited: May 13, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    That's the first time I hear of such a problem. Have you compared your configuration with the one from the tutorial to rule out typos?
     
  3. max0r

    max0r New Member

    Hello Falko, thanks for your time.

    I did what you told and i found the following error on configuration:

    in /usr/lib/sasl2/smtpd.conf

    Code:
    pwcheck_method: authdaemond
    log_level: 3
    mech_list: PLAIN LOGIN
    authdaemond_path:/var/spool/authdaemon/socket
    i forgot to change the pwcheck_method, so i did it and switched it to "authdaemon"

    Now i cannot send from any account (but i do receive very well, using IMAP), and i got the following error message:

    Code:
    postfix/smtpd[20338]: warning: SASL authentication problem: unknown password verifier
    postfix/smtpd[20338]: warning: unknown[192.168.111.119]: SASL LOGIN authentication failed
    postfix/smtpd[20338]: lost connection after AUTH from unknown[192.168.111.119]
    Any help would be appreciated!
     
    Last edited: May 13, 2008
  4. max0r

    max0r New Member

    Solved!

    Solved! It was a simple problem after all!

    I had to restart "Postfix" and "saslauth" in the following order

    /etc/init.d/postfix stop
    /etc/init.d/saslauth restart
    /etc/init.d/postfix start

    :D
     

Share This Page