Postfix set-up

Discussion in 'Server Operation' started by latcarf, Aug 14, 2005.

  1. latcarf

    latcarf New Member

    Can anyone point me to a HowTo for setting up postfix after install?

    I prowled around the forum enough to discover some files such as postfix's main.cf, virtualusertable, and local-host-names.

    main.cf has everything commented out and does not mention my domain name or anything else. virtualusertable and local-host-names appear to be blank documents and "cant be displayed"

    I am making a pretty good guess that this needs to be done before I can send and recieve mail for my domain through this mail server.

    Thanks
    Lance
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    If you use ISPconfig, then /etc/postfix/local-host-names and /etc/postfix/virtusertable are handled by ISPconfig.
     
  3. latcarf

    latcarf New Member

    Okay I am back to my original question above since I won't be using ISPConfig for now.

    I set up an account in Mozilla. My mail account is set up as; where it says POP Mail Server I have mail.thefractalfarm.net. For the Outing Server Settings I have the server name as smtp.thefractalfarm.net. I suspect the smtp is correct but should the inbound be pop or pop3 instead of mail?

    It was failing to connect before but I got my DNS records squared away and now it is asking me for a password. I don't recall setting one! I tried my Linux root and user passwords but they did not work.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can use any domain that is pointing to your server, and you can enter it as POP3 server and as SMTP server. But for simplivity I'd recommend that you simply use the IP address of your box, then you'll have no problems with your DNS settings.
     
  5. latcarf

    latcarf New Member

    thanks falko, I finally got it working.

    In my email client (Mozilla) for in-coming and out-going mail all I had to do was enter the mail server name, e.g. [mailserverhostname].[my-domain].[tld].

    It kept asking me for a password but again I don't recall ever setting one and my root or user password did not work. After much reading I finally found a reference on the web to setting user and password for postfix
    Code:
    # adduser [username] 
    # passwd [username] [password]
    After I did that I was able to finally get mail.

    Now sending mail was another story. It wouldn't connect and that is when I changed the smtp server name in Mozilla to my mail server name as described above. That change enabled Mozilla to connect for sending mail but then I got an error regarding my certificates. I have an idea it relates to when I installed postfix and made the certificates.

    When setting up the certificates duiring install with the HowTo we need to enter

    "Company Name" should this be our FQDN?
    "Unit Name" what do we enter here? :confused:
    "Server Host" name should be what? FQDN, mail server name :confused:

    I have an idea the Server Host name probably needs to be the server name of my mail server as I entered in Mozilla above and as defined in my zone files. Am I on the right track?

    lance
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    No, not the FQDN, it's the company name, like ACME, Inc.
    Something like IT Department or so.

    Yes, your mailserver name, like mailserver.example.com.
     
  7. latcarf

    latcarf New Member

    thanks, that will probably solve the problem with the certificate validation then. I put server1 without the FQDN when I installed.

    Now the problem is how do I edit the certificate(s)? If I run through the certificate steps again in your HowTo will it regenerate them without problems? and should I shut sown postfix while I do it?

    lance
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I think so. Haven't tried yet, but I don't see why it shouldn't work... :)
     
  9. latcarf

    latcarf New Member

    okay, I'll let you know what happens :)
     
  10. latcarf

    latcarf New Member

    It seemed to work since I did not get any errors on the console or during retart. Although when I sent my first message I did get a screen asking if I wanted to verify sertificate, before I received a series of error massages regarding the certificates then the window I just mentioned. It also gave me the option at the bottom to Always accept, Accept this time, or never accept. I chose Always except.

    thanks for the help :)
    lance
     

Share This Page