Postfix/Sendmail Problem

Discussion in 'Installation/Configuration' started by Mr. Print, Jul 6, 2009.

  1. Mr. Print

    Mr. Print New Member

    Running Fedora 8, ISPConfig 2.2.32, postfix, dovecot, Coldfusion 8. It is my understanding that you cannot run sendmail and postfix together from reading the post on this forum.

    All mail accounts will send and receive mail, FormMail will deliver mail to local user. However, other forms that use sendmail 97% of the time will not send out mail. It is my understanding that Postfix will do the same task that sendmail does.

    Can someone direct me in how I can fix this problem. One last question that may play an important part in this; the primary and secondary dns for the server network, should it be the primary and secondary dns from your ISP?

    Thank's for your time and patience!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up the sendmail mta and the sendmail helper binary from postfix. If a form uses sendmail then this means that the program with the name sendmail which is part of postfix is used and not that you have to install the sendmail MTA.

    If you have a problem with sending emails, please look at the mail log and compare successful and unsucessful email sending attempts.
     
  3. Mr. Print

    Mr. Print New Member

    Thanks for your reply Till. Viewed the mail log,

    Jul 6 13:07:14 host postfix/cleanup[32279]: 1C3521060A01: message-id=<[email protected]>
    Jul 6 13:07:14 host postfix/qmgr[22768]: 1C3521060A01: from=<[email protected]>, size=886, nrcpt=1 (queue active)
    Jul 6 13:07:14 host sendmail[32275]: n66H78uc032275: to=[email protected], ctladdr=apache (48/48), delay=00:00:06, xdelay=00:00:06, mailer=relay, pri=30327, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 1C3521060A01)
    Jul 6 13:07:14 host postfix/smtpd[32276]: disconnect from localhost.localdomain[127.0.0.1]
    Jul 6 13:07:19 host postfix/smtp[32283]: 1C3521060A01: to=<[email protected]>, relay=mail.domainname.com[64.26.60.153]:25, delay=10, delays=5.4/0.01/4.6/0.09, dsn=4.0.0, status=deferred (host mail.domainname.com[64.26.60.153] said: 450 <[email protected]>: Sender address rejected: Domain not found (in reply to RCPT TO command))

    Real domain name replaced with "domainname" If you notice the domain name on this server is .net and I have the same domain name that is .com on another server that is hosted by another company. Log states; "Sender address rejected: Domain not found (in reply to RCPT TO command))

    Any help here will be greatly appreciated
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that a DNS A-Record for host.domainname.net exists (and not just for domainname.net) that points to your server IP address.
     
  5. Mr. Print

    Mr. Print New Member

    Can you explain a little, really new to Linux, would this be with the registrar or on local server.

    Thanks for your time.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    DNS Records have always be created on the DNS server that is authoritive for the domain. If you dont know which server II'am talking about, then it is most likely the server of your provider and not your own server.
     
  7. Mr. Print

    Mr. Print New Member

    Problem Solved. Took some digging for I didn't totally understand. I added a host with the server IP address and that solved the problem:

    A Record:
    IP-Adresse Hostname
    173.8.xx.xx ns1
    173.8.xx.xx www
    173.8.xx.xx mail
    192.168.0.19 host

    If you notice anything that shouldn't be here please advise.
     
    Last edited: Jul 8, 2009

Share This Page