Postfix sending to domain on same network

Discussion in 'Server Operation' started by ewettach, Sep 19, 2006.

  1. ewettach

    ewettach New Member

    I have two email servers --- 1 server is named mail0 with ip address of 192.168.255.131 and recives and sends email for domain example0.com. The other server is named mail1 with ip address of 192.168.255.137 and recives and sends email for domain example1.com. They are both on the dmz of our router. Both have their own independent static public ip address. I am running imail on mail0 and can send email to mail1. To do this i added mail1 in the hosts file in C:\winnt\system32. However I cannot get mail1 to send email to mail0. I get a connection timed out because it is trying to send mail from mail1 to the public ip of mail0. How do I make mail1 send to the local ip of mail0? I am running Postfix and Courier with Mysql Support on mail1.

    I have added mail0 in the /etc/hosts file and when i run "telnet example0.com 25" it works and translates it to the local ip. But in the /var/log/mail.log it says its trying public ip. Thanks in advance.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If your Postfix is running chrooted (which it does in most installations), you must also change /var/spool/postfix/etc/hosts.
     
  3. ewettach

    ewettach New Member

    Thanks for your reply, however, /var/spool/postfix/etc/hosts is identical to my /etc/hosts
     
  4. ewettach

    ewettach New Member

    Ok I was finally able to get it to work by....
    adding

    smtp_host_lookup=native

    in main.cf

    Thanks for your help.
     

Share This Page