Postfix sending mail to wrong mailbox/user

Discussion in 'Installation/Configuration' started by 3cwired_com, Oct 27, 2006.

  1. 3cwired_com

    3cwired_com New Member

    I tried to do a search which didn't turn up anything, but I recently installed CentOs 4.4, and the latest ISPConfig, as per the tutorial, the only problem is, now when I test my webmail, which I use roundcube, mail from 2 of my domains goes to 1 particular domain. For instance domains domain1.com, and domain2.com, all mail from both domains end up at domain1.com. I can send mail from domain2.com, and if i reply to it, it ends up at domain1.com.

    Please advise.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. 3cwired_com

    3cwired_com New Member

    Here is my main.cf file, I can't find what you are talking about can you be more specific?

    Main.cf file:

    queue_directory = /var/spool/postfix

    command_directory = /usr/sbin

    daemon_directory = /usr/libexec/postfix

    mail_owner = postfix

    inet_interfaces = all

    unknown_local_recipient_reject_code = 550

    alias_maps = hash:/etc/aliases

    alias_database = hash:/etc/aliases

    debug_peer_level = 2

    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5

    sendmail_path = /usr/sbin/sendmail.postfix

    newaliases_path = /usr/bin/newaliases.postfix

    mailq_path = /usr/bin/mailq.postfix

    setgid_group = postdrop

    html_directory = no

    manpage_directory = /usr/share/man

    sample_directory = /usr/share/doc/postfix-2.2.10/samples

    readme_directory = /usr/share/doc/postfix-2.2.10/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
     
  4. 3cwired_com

    3cwired_com New Member

  5. 3cwired_com

    3cwired_com New Member

    I guess a quick fix would be to disable catchall from the one thats getting all of the emails, but is there a right way to fix this???
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Set mydomain and/or myhostname in /etc/postfix/main.cf. You should use a technical domain for it, i.e., a domain that you don't use for webhosting, email, etc.
     
  7. 3cwired_com

    3cwired_com New Member

    I saw you post the same thing in another thread... what if I don't have a domain name that isnt for hosting, etc... I mean, thats the purpose of all of my domains, for either web/email. What would I do next?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You need a technical domain or at least one domain where you did not enable a ctachall record.

    You may also use a subdomain like server1.yourcompanydomain.com as technical domain.
     
  9. 3cwired_com

    3cwired_com New Member

    Thanks for the reply, I will try it out, and report back to you guys.
     

Share This Page