PostFix says it's started but never runs

Discussion in 'Server Operation' started by badgerbox76, Aug 7, 2009.

  1. badgerbox76

    badgerbox76 Member

    I have already run apt-get --purge remove postfix and reinstalled it but I am still getting this error below. I am not sure where to go from here. Any help would be appreciated.

    Code:
    [email protected]:/etc/init.d# telnet localhost 25
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    [email protected]:/etc/init.d#
    
    Code:
    [email protected]:/etc/init.d# ./postfix start
     * Starting Postfix Mail Transport Agent postfix                                                                                                                                                         [ ok ]
    [email protected]:/etc/init.d# ./postfix start
     * Starting Postfix Mail Transport Agent postfix                                                                                                                                                         [ ok ]
    [email protected]:/etc/init.d# ./postfix check
    postfix/postfix-script: warning: not owned by postfix: /var/lib/postfix/./master.lock
    postfix/postfix-script: warning: not owned by postfix: /var/lib/postfix/./smtpd_scache.db
    postfix/postfix-script: warning: not owned by postfix: /var/lib/postfix/./smtp_scache.db
    [email protected]:/etc/init.d#
    
    Code:
    [email protected]:/var/lib/postfix# ls -l
    total 24
    -rw------- 1 fetchmail postfix   17 Mar 30 08:45 master.lock
    -rw------- 1 postfix   postfix 1024 Oct  5  2008 prng_exch
    -rw------- 1 fetchmail postfix 8192 Oct  5  2008 smtp_scache.db
    -rw------- 1 fetchmail postfix 8192 Oct  5  2008 smtpd_scache.db
    [email protected]:/var/lib/postfix#
    
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    Code:
    chown postfix.postfix -R /var/lib/postfix
    /etc/init.d/postfix restart
     

Share This Page