postfix/saslauthd/etc. SMTP problems after update

Discussion in 'HOWTO-Related Questions' started by qtx, Dec 1, 2006.

  1. qtx

    qtx New Member

    Hi evr'1

    I did a bad thing :(
    I wasn't paying attention while upgrading my debian-Server.

    My installation includes the mailserver-solution from falko (Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)).
    After upgraded my system, I cannot send mails (smtp) anymore.

    The following errors while trying to authenticate (mail.log):

    Code:
    Dec  1 12:14:25 localhost postfix/smtpd[14084]: warning: SASL authentication failure: Password verification failed
    Dec  1 12:14:25 localhost postfix/smtpd[14084]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed: generic failure
    Dec  1 12:14:26 localhost postfix/smtpd[14084]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    After cancelling the SMTP-Auth in the mail client:

    Code:
    Dec  1 12:14:26 localhost postfix/smtpd[14084]: warning: localhost[127.0.0.1]: SASL LOGIN authentication failed: generic failure
    Dec  1 12:14:29 localhost postfix/smtpd[14084]: lost connection after AUTH from localhost[127.0.0.1]
    Dec  1 12:14:29 localhost postfix/smtpd[14084]: disconnect from localhost[127.0.0.1]
    I am stuck here.
    I checked every conf-file but did not find anything.
    Starting the daemons (postfix, amavisd-new etc.) is no problem, and as I mentioned reveiving mails works just fine.

    Can someone 'light me up'?
    OR
    What would I have to do to return to the 'old' setting (before upgrading)?

    Thanks in advance for any help!
    QT
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You shouldn't have updated Postfix because you've lost the quota patch now.

    I suggest you configure yor system again following the tutorial.
     
  3. qtx

    qtx New Member

    That's definitely not an option! :)

    It was a permission problem on the sasl socket directory, after all!

    Everything works fine again.

    The 'quota'-issue is not a big loss in my case.

    Anyway, thanks for the input.
     
  4. Khushil

    Khushil New Member

    What changes...

    qtx: Care to elaborate on what fixes you applied to get it working? What permission changes did you make please? I'm in the same situation...
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    chmod 777 /var/spool/postfix/var/run/saslauthd
     
  6. Khushil

    Khushil New Member

    Great! Worked. Thanks mate. Does anyone know of any links to explain more about the full install of SASL authentication at all? Something readable?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Ok. You should now open /etc/init.d/saslauthd. There's a chmod line somewhere near the beginning. Comment it out because otherwise the script will change the permissions of /var/spool/postfix/var/run/saslauthd everytime you restart saslauthd.
     

Share This Page