Postfix relay problem

Discussion in 'Server Operation' started by asus, Jun 25, 2008.

  1. asus

    asus New Member

    ok now I have run into another problem with outgoing email. I'm trying to relay my outgoing email through my ISP email @ rogers.com but now I get this

    Code:
    Jun 25 11:11:21 gwi postfix/smtp[29061]: warning: valid_hostname: empty hostname
    Jun 25 11:11:21 gwi postfix/smtp[29061]: warning: malformed domain name in resource data of MX record for smtp.broadband.rogers.com: 
    Jun 25 11:11:21 gwi postfix/smtp[29061]: warning: valid_hostname: empty hostname
    Jun 25 11:11:21 gwi postfix/smtp[29061]: warning: malformed domain name in resource data of MX record for smtp-rog.mail.yahoo.com: 
    Jun 25 11:11:21 gwi postfix/smtp[29061]: warning: relayhost configuration problem
     
  2. topdog

    topdog New Member HowtoForge Supporter

    post your main.cf
     
  3. asus

    asus New Member

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = no
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = gwi.bounceme.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = gwi.bounceme.net, localhost.bounceme.net, localhost.localdomain, localhost
    relayhost = smtp.broadband.rogers.com
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options = 
     
  4. topdog

    topdog New Member HowtoForge Supporter

    You need to make this change
    Code:
    relayhost = [smtp.broadband.rogers.com]
     
  5. asus

    asus New Member

    thank top dog that worked. i followed the postfix relay howto, So maybe someone should add that into that howto.
     
  6. asus

    asus New Member

    ok now i have ran into this
    Code:
    Jun 26 11:58:49 gwi postfix/smtp[28839]: 30FB71343EF: to=<[email protected]>, relay=smtp.broadband.rogers.com[206.190.36.18]:25, delay=0.54, delays=0.14/0.04/0.33/0.03, dsn=5.0.0, status=bounced (host smtp.broadband.rogers.com[206.190.36.18] said: 553 From: address not verified; see http://www.rogershelp.com/verify-email (in reply to MAIL FROM command))
    Jun 26 11:58:49 gwi postfix/cleanup[28837]: B81C3134498: message-id=<[email protected]>
    Jun 26 11:58:49 gwi imapd: LOGOUT, user=web1_adam, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=418, time=0
    Jun 26 11:58:49 gwi postfix/qmgr[28776]: B81C3134498: from=<>, size=2753, nrcpt=1 (queue active)
    Jun 26 11:58:49 gwi postfix/bounce[28843]: 30FB71343EF: sender non-delivery notification: B81C3134498
    Jun 26 11:58:49 gwi postfix/qmgr[28776]: 30FB71343EF: removed
    Jun 26 11:58:50 gwi postfix/smtp[28839]: B81C3134498: to=<[email protected]>, relay=smtp.broadband.rogers.com[206.190.36.18]:25, delay=0.39, delays=0.03/0/0.34/0.03, dsn=5.0.0, status=bounced (host smtp.broadband.rogers.com[206.190.36.18] said: 553 From: address not verified; see http://www.rogershelp.com/verify-email (in reply to MAIL FROM command))
    Jun 26 11:58:50 gwi postfix/qmgr[28776]: B81C3134498: removed
    Jun 26 11:58:52 gwi imapd: Connection, ip=[::ffff:127.0.0.1]
    I noticed that [email protected] that shouldn't be there I don't recall putting in example in anywhere when installing
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mailname?
     
  8. asus

    asus New Member

    gwi.bounceme.net
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Ok. What are the outputs of
    Code:
    hostname
    and
    Code:
    hostname -f
    ?
     
  10. asus

    asus New Member

    the same gwi.bounceme.net
     
  11. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    postconf -d | grep example.com
    and
    Code:
    postconf -n | grep example.com
    ?
     
  12. asus

    asus New Member

    nothing came up for both.
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Then I don't know why you see example.com in your log...
     
  14. asus

    asus New Member

    ok..... thanks for the help . I will try and figure it out.
     
  15. Zarteg

    Zarteg New Member

    Rogers Postfix Relay Problem

    The postfix or for that matter sendmail relay mail problem can be caused by using Rogers ISP.

    To send e-mail you now have to login your rogers.yahoo.com account and add any "From" addresses that will be sending through your connection.
    The maximum is 10 minus your default Rogers account so in reality 9.

    Go To http://rogers.yahoo.com
    login to the website (your account)

    Go To "Mail"
    Go To "Options"
    Under Management Go To "Mail Accounts"

    Figure out what your relay is trying to send as
    eg: "[email protected]" and add it.
     

Share This Page