PostFix Relay Issue

Discussion in 'Installation/Configuration' started by jcoen, Mar 25, 2008.

  1. jcoen

    jcoen New Member

    Thanks for reading.

    I have PostFix running on "The Perfect Etch Setup".

    At first, it wasn't authenticating. I think that was because I didn't have maildir checked in ISPConfig.

    But now, it is authenticating, and receiving mail from several of my email accounts, but it is not sending mail.

    I get a message saying:

    =================

    Your message did not reach some or all of the intended recipients.

    Subject: Test
    Sent: 3/23/2008 8:51 PM

    The following recipient(s) could not be reached:

    '[email protected]' on 3/23/2008 8:51 PM
    554 5.7.1 < HYPERLINK "mailto:[email protected]" [email protected]>: Relay access denied

    =================

    A little more history:

    There are 2 domains explained herein. One is a sub-domain which is the name of the server itself. The other is a domain hosted on this server. The email/domain hosted on the server doesn't send mail. Just receives mail.

    This server, "The Perfect Etch Setup" running Postfix is a actually named as a sub-domain of another domain ...

    I use Outlook to authenticate (Please don't flame me about using Microsoft), so POP and SMTP settings are both set to the sub-domain name.

    Is this a sub-domain name issue or does that matter? I tried going into DNS management for the domain and changing the MX record to just the IP address thinking that was the issue, and DNS doesn't like just the IP address of my mail server.

    Anyone have any ideas?

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. jcoen

    jcoen New Member

    It's not listed in there because that domain is not hosted on this server. It's hosted elsewhere.

    Surely it doesn't have to be in there to 'send' mail, does it?
     
  4. jcoen

    jcoen New Member

    OK, OK. I'm a noob.

    Here's a caveat: I'm so used to running through cable internet that requires me to throw all email off their SMTP server and it doesn't require authentication. I recently got a static IP and all this is new to me ...

    So come to find out, all I had to do is go in and set my Outlook to “My outgoing server (SMTP) requires authentication” and put in the login credentials.

    Bingo!

    I sure hope this helps someone. Because being such a noob I can't give any suggestions to these major issues ... yet.
     
  5. mspIggy

    mspIggy New Member

  6. jcoen

    jcoen New Member

    PostFix won't authenticate

    Iggy:

    The way I fixed it was a setting in my Outlook.

    Under "Accounts", there is a setting for "My Outgoing Mail Server Requires Authentication". I selected that and had no more problems.

    On my server, "The Perfect Etch Setup", the server won't blindly relay unauthenticated mail. Once Outlook authenticated to the server to send mail, everything worked perfectly.

    Hope this helps.
     

Share This Page