Postfix - Reject incoming email for specific user

Discussion in 'Tips/Tricks/Mods' started by richi, Feb 17, 2009.

  1. richi

    richi New Member HowtoForge Supporter

    Hi Folks,

    while using ISPconfig for quite a long time i was confronted with the fact of growing files within the /var/spool/mail directory.

    I think this happens because postfix accepts mail for every system user which is the normal behaviour?!

    So even when postfix is configured to accept mail only for "valid email users" that are mapped via virtusertable to "real system users", emails for the Linux "default users" like nobody uucp or mail are accepted and delivered.

    One solution to this is to reject those unwanted mails using smtpd_recipient_restrictions defined within

    Adding there "check_recipient_access hash:/etc/postfix/denied_recipients" before the "permit_mynetworks" statement allows you to reject those unwanted mails.

    After adding them to this file (one address per line) in the form of

    [email protected] REJECT recipient rejected

    don´t forget to run

    postsuper /etc/postfix/denied_recipients

    and restart postfix.

    On my systems i am using Debian Etch and perhaps there are other ways to achieve this, but for me it did the trick.
    Last edited: Feb 17, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you dont wabt this behaviour, change the email style from sendmail to postfix in the file and then change a email user in ispconfig to update the config files.
  3. richi

    richi New Member HowtoForge Supporter

    Thanks for the Info, but since the "sendmail style" is the default for ISPconfig i would have to change this with every update of the Software. So the other solution keeps working after the update without additional configuration, or do i miss something here?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig remembers its config settings ;)

Share This Page