Postfix refusing smtp connections

Discussion in 'Installation/Configuration' started by chrisc, Jul 16, 2006.

  1. chrisc

    chrisc New Member

    Hi there,

    The HDD in my server failed the other day, so I though I'd take the opportunity to give ISPConfig a go.

    I followed the Ubuntu 6.06 HOWTO but seem to have been left with a setup where Postfix refuses any incoming connections on Port 25.

    I'm sure I'm missing something obvious, but for the life of me can't see what.

    Here's my postfix conf:
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    append_dot_mydomain = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    myhostname = hub.chriscole.info
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = hub.chriscole.info, localhost.chriscole.info, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    Firewall is off (and iptables -L is empty).

    From the server itself, telnet localhost 25 with ehlo localhost gives:
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 hub.chriscole.info ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-hub.chriscole.info
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    When I try to connect on Port 25 from 'remote' machine (this box is not currently connected to the internet, so it's just another machine behind a switch setup on the same subnet), nothing gets recorded in /var/log/mail.log - only error the client sees is "connection refused"

    Any suggestions would be much appreciated,

    Chris.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you enable smtp-auth in your email client?
    Did you try webmail, are you able to send emails with webmail?
    Did you get any errors when you restart postfix?

    If you try to send email to a local recipient:

    Is the domain listed in /etc/postfix/local-host-names?
    Is the recipient listed in /etc/postfix/virtusertable?
     
  3. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    It sounds like a firewall error.. see the "Connection refused" error.
     
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    or you just try a

    tcpdump dst port 25 -w capture.cap

    on your clientmachine (or ethereal in case of Windows) to see if your connection gets replied, if this is a connection problem.

    Is sth. listening on Port 25 on your server?
     
  5. chrisc

    chrisc New Member

    Ahem - rather stupid error on my part. Forgot that McAfee Virusscan was blocking port 25 by default on the laptop I was using. Turned that off and everything works fine.

    Chris.
     

Share This Page