Postfix refude to send email

Discussion in 'Server Operation' started by a3das, May 1, 2013.

  1. a3das

    a3das New Member

    (Postfix version) /etc/postfix/ = 2.3.8

    (OS Version) bash-2.03#uname -a SunOS blade 5.8 Generic_108528-17 sun4u sparc SUNW,Sun-Blade-100

    (changed configs)

    bash-2.03# postconf -n
    alias_database = dbm:/etc/aliases
    alias_maps = dbm:/etc/aliases
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    content_filter = imss:localhost:10025
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    debug_peer_list =
    default_process_limit = 200
    html_directory = no
    local_recipient_maps =
    mail_owner = postfix
    mailq_path = /usr/bin/mailq
    manpage_directory = /usr/local/man
    message_size_limit = 10240000
    mydestination =, localhost, localhost.$mydomain, $myhostname
    mydomain =
    myhostname =
    mynetworks =,,
    mynetworks_style = class
    myorigin = $myhostname
    newaliases_path = /usr/bin/newaliases
    queue_directory = /var/spool/postfix
    readme_directory = /postfix.old/postfix-2.3.8/readme_directory
    relay_domains = $mydestination
    relayhost = $mydomain
    sample_directory = /etc/postfix
    sendmail_path = /usr/lib/sendmail
    setgid_group = postdrop
    unknown_local_recipient_reject_code = 450
    when i try to send an email to Gmail i get this response, which means that postfix tends to look for gmail server in loop-back network. this will fail always. response is below

    sendmail [email protected] <"tst"
    <[email protected]>: connect to localhost[]: Connection refused
    Content-Description: Delivery report
    Content-Type: message/delivery-status
    Reporting-MTA: dns;
    X-Postfix-Queue-ID: 970FE58DA
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Wed, 5 Dec 2012 11:06:09 +0200 (Asia/Amman)
    Final-Recipient: rfc822; [email protected]
    Action: delayed
    Status: 4.4.1
    Diagnostic-Code: X-Postfix; connect to localhost[]: Connection refused
    when i use what-if-mode , postfix will actually go and search for gmail server and finds it, and confirm the deliverablity of this email. response is below:

    sendmail -bv [email protected] <"test"
    Dec 5 10:57:52 blade postfix/smtp[15906]: [ID 197553] 6447958DA: to=<[email protected]>,[]:25, delay=1.8, delays=0.08/0.03/1.5/0.26, dsn=2.1.5, status=deliverable (250 2.1.5 OK u8si15432094wiw.9)
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?

    What's the output of
    netstat -tapn
  3. a3das

    a3das New Member

    Thank you for you reply ...

    i get this on /var/log/syslog
    this the output: (-t command is not supported)

  4. a3das

    a3das New Member

    any boddy

    any help everyone ??
  5. dalitso

    dalitso New Member

  6. a3das

    a3das New Member

    same as gmail

    i got the same respons as if sent it to a gmail

    May 14 15:43:32 blade postfix/smtp[20568]: [ID 197553] C3C7A59EF: to=<[email protected]>, relay=none, delay=0.11, delays=0.08/0.03/0.01/0, dsn=4.4.1, status=deferred (connect to localhost[]: Connection refused)

Share This Page