Postfix: REceive mails but Doesn't Send mails to others externals domains

Discussion in 'General' started by angelux, Aug 8, 2008.

Thread Status:
Not open for further replies.
  1. angelux

    angelux New Member

    Hello, I was reading all the post about this issue but don't solved in mi server.

    As I said I can receive emails from externals emails like gmail, hotmail, etc. But the PostFix can't send to externals domains, that's my problems, I do the http://www.howtoforge.com/perfect_setup_debian_etch_p5 Setup and everything are like that configurations, but I left my main.cf:

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = server1.angelux.info
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server1.angelux.info, localhost.angelux.info, , localhost
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    Please someone who knows how to solved.

    PD: I'm using the ISPConfig Panel on a Debian 4 64bits

    This the last part of the big mail.log file:

    Code:
    Aug  7 06:24:17 server1 postfix/smtpd[6312]: connect from unknown[122.2.170.214]
    Aug  7 06:24:19 server1 postfix/smtpd[6312]: NOQUEUE: reject: RCPT from unknown[122.2.170.214]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<122.2.170.214.pldt.net>
    Aug  7 06:24:19 server1 postfix/smtpd[6637]: connect from unknown[67.224.169.123]
    Aug  7 06:24:20 server1 postfix/smtpd[6312]: disconnect from unknown[122.2.170.214]
    Aug  7 06:24:21 server1 postfix/smtpd[6637]: NOQUEUE: reject: RCPT from unknown[67.224.169.123]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<[67.224.169.123]>
    Aug  7 06:24:22 server1 postfix/smtpd[6637]: disconnect from unknown[67.224.169.123]
    Aug  7 06:24:33 server1 postfix/smtpd[6312]: connect from unknown[217.165.250.60]
    Aug  7 06:24:34 server1 postfix/smtpd[6312]: NOQUEUE: reject: RCPT from unknown[217.165.250.60]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<dxb-as36382.alshamil.net.ae>
    Aug  7 06:24:34 server1 postfix/smtpd[6312]: lost connection after DATA from unknown[217.165.250.60]
    Aug  7 06:24:34 server1 postfix/smtpd[6312]: disconnect from unknown[217.165.250.60]
    Aug  7 06:24:45 server1 postfix/smtpd[6637]: connect from unknown[203.172.212.193]
    Aug  7 06:24:46 server1 postfix/smtpd[6637]: NOQUEUE: reject: RCPT from unknown[203.172.212.193]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<gnksk>
    Aug  7 06:24:47 server1 postfix/smtpd[6637]: disconnect from unknown[203.172.212.193]
    Edit: Today i was trying again and when i send a mails this was the last logs:
    Code:
    Aug  8 20:24:15 server1 postfix/smtpd[14887]: lost connection after RCPT from unknown[201.29.204.112]
    Aug  8 20:24:15 server1 postfix/smtpd[14887]: disconnect from unknown[201.29.204.112]
    Aug  8 20:24:18 server1 postfix/smtpd[14905]: connect from localhost.localdomain[127.0.0.1]
    Aug  8 20:24:18 server1 postfix/smtpd[14905]: 7941033E4037: client=localhost.localdomain[127.0.0.1]
    Aug  8 20:24:18 server1 postfix/cleanup[14886]: 7941033E4037: message-id=<[email protected]>
    Aug  8 20:24:18 server1 postfix/qmgr[14701]: 7941033E4037: from=<[email protected]>, size=691, nrcpt=1 (queue active)
    Aug  8 20:24:18 server1 postfix/smtpd[14905]: disconnect from localhost.localdomain[127.0.0.1]
    Aug  8 20:24:18 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug  8 20:24:18 server1 imapd: LOGIN, user=web8_test2, ip=[::ffff:127.0.0.1], protocol=IMAP
    Aug  8 20:24:18 server1 imapd: LOGOUT, user=web8_test2, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=40, sent=110, time=0
    Aug  8 20:24:18 server1 postfix/smtp[14909]: 7941033E4037: to=<[email protected]>, relay=none, delay=0.09, delays=0.05/0.03/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=gmail.com type=AAAA: Host found but no data record of requested type)
    Aug  8 20:24:18 server1 postfix/cleanup[14886]: 959C233E42CE: message-id=<[email protected]>
    Aug  8 20:24:18 server1 postfix/qmgr[14701]: 959C233E42CE: from=<>, size=2777, nrcpt=1 (queue active)
    Aug  8 20:24:18 server1 postfix/bounce[14911]: 7941033E4037: sender non-delivery notification: 959C233E42CE
    Aug  8 20:24:18 server1 postfix/qmgr[14701]: 7941033E4037: removed
    Aug  8 20:24:18 server1 postfix/smtp[14909]: 959C233E42CE: to=<[email protected]>, relay=none, delay=0.02, delays=0.01/0/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=example.com type=AAAA: Host found but no data record of requested type)
    Aug  8 20:24:18 server1 postfix/qmgr[14701]: 959C233E42CE: removed
    Aug  8 20:24:18 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug  8 20:24:18 server1 imapd: LOGIN, user=web8_test2, ip=[::ffff:127.0.0.1], protocol=IMAP
    Aug  8 20:24:19 server1 imapd: LOGOUT, user=web8_test2, ip=[::ffff:127.0.0.1], headers=568, body=0, rcvd=223, sent=1792, time=1
    Aug  8 20:24:23 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug  8 20:24:23 server1 imapd: LOGIN, user=web8_test2, ip=[::ffff:127.0.0.1], protocol=IMAP
    Aug  8 20:24:23 server1 imapd: LOGOUT, user=web8_test2, ip=[::ffff:127.0.0.1], headers=0, body=2075, rcvd=174, sent=2996, time=0
    Aug  8 20:24:26 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug  8 20:24:26 server1 imapd: LOGIN, user=web8_test2, ip=[::ffff:127.0.0.1], protocol=IMAP
    Aug  8 20:24:26 server1 imapd: LOGOUT, user=web8_test2, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=418, time=0
    Aug  8 20:24:29 server1 postfix/smtpd[14705]: disconnect from unknown[209.85.198.250]
    Aug  8 20:24:33 server1 postfix/smtpd[14887]: connect from unknown[64.126.86.24]
    Aug  8 20:24:33 server1 postfix/smtpd[14905]: connect from unknown[201.29.98.221]
    Aug  8 20:24:34 server1 postfix/smtpd[14887]: NOQUEUE: reject: RCPT from unknown[64.126.86.24]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<64-126-86-24.dyn.everestkc.net>
    Aug  8 20:24:34 server1 postfix/smtpd[14905]: NOQUEUE: reject: RCPT from unknown[201.29.98.221]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<20129098221.user.veloxzone.com.br>
    Aug  8 20:24:34 server1 postfix/smtpd[14887]: disconnect from unknown[64.126.86.24]
    Aug  8 20:24:35 server1 postfix/smtpd[14905]: disconnect from unknown[201.29.98.221]
    
     
    Last edited: Aug 8, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this server located in a datacaenter or do you run it on a DSL line?
     
  3. angelux

    angelux New Member

    Yes, Till, the server is in a Datacenter and many Publics IPs

    :(
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/resolv.conf?
     
  5. angelux

    angelux New Member

    yeah, thanks!

    i do:

    # host -t MX gmail.com
    Host Not Found

    it was the error, I was reading a lot on the net and it was about the named.conf bind9 file, one day before I aplied a patch there and that was the error son abyone else with this problem, check your DNS configurations.

    Thanks! any moderator can close this thread.
     
Thread Status:
Not open for further replies.

Share This Page