Postfix queueing messages suddenly, connection timed out.

Discussion in 'Server Operation' started by macwise, Nov 9, 2005.

  1. macwise

    macwise New Member

    I am having a problem with my postfix server. It was working fine, but
    suddenly the emails that are supposed to automatically be sent from one
    of my PHP sites are showing connection timed out. Here is the tail of
    my /var/log/maillog/. Below that under the lines is a portion of the
    mailq results.

    Nov 9 13:16:11 localhost ipop3d[13087]: Logout user=spamkiller [68-6-XX-XXX] nmsgs=0 ndele=0
    Nov 9 13:16:11 localhost ipop3d[13086]: Logout user=ME [68-6-XX-XXX] nmsgs=98 ndele=0
    Nov 9 13:16:23 localhost postfix/pickup[12930]: 83061461D33: uid=99
    Nov 9 13:16:23 localhost postfix/cleanup[12936]: 83061461D33:
    Nov 9 13:16:23 localhost postfix/nqmgr[12931]: 83061461D33:
    from=<>, size=1433, nrcpt=1 (queue active)
    Nov 9 13:16:23 localhost postfix/pickup[12930]: 8A10C461D42: uid=99
    Nov 9 13:16:23 localhost postfix/cleanup[12936]: 8A10C461D42:
    Nov 9 13:16:23 localhost postfix/nqmgr[12931]: 8A10C461D42:
    from=<>, size=1441, nrcpt=1 (queue active)
    Nov 9 13:16:23 localhost postfix/trivial-rewrite[13091]: warning: do
    not list domain in BOTH mydestination and
    Nov 9 13:16:23 localhost postfix/local[12938]: 8A10C461D42:
    to=<>, orig_to=<>,
    relay=local, delay=0, status=sent (mailbox)

    --------------------------------------------------------------------------- ----------------------------------------------------------
    mailq entry:
    --------------------------------------------------------------------------- ----------------------------------------------------------

    A9FB8461D35 1434 Sun Nov 6 20:29:34
    (connect to[]: Connection
    timed out)

    939D4461D38 1457 Tue Nov 8 19:34:15
    (connect to[]: Connection
    timed out)

    9E36F461D3E 1433 Tue Nov 8 23:15:26
    (connect to[]: Connection
    timed out)

    I cannot seem to find where the problem is. I tried setting the
    disable_dns_lookup=no, but this didn't help. I don't know where else
    to look to resolve this issue. BTW, when I telnet to these ip
    addresses from my box, I am able to connect just fine. Port 25 isn't
    blocked by the ISP. :eek:
  2. till

    till Super Moderator

    Have you tried to remove from virtual_alias_domains? Did you get the email problem with all PHP scripts or only with one special script?
  3. macwise

    macwise New Member

    Which file should I modify to remove from the virtual_alias_domains, and how should the line read when I modify it?

    Is this the virtual file that I need to modify?
  4. falko

    falko Super Moderator

    It's the file /etc/postfix/
  5. macwise

    macwise New Member

    got it figured out

    Thanks for your help, everybody. The problem was that I had changed mail to port 26 in /etc/services about 2 weeks ago. I did this in an attempt to be able to move the box to my house, as I am on cable internet. It ended up not working (for obvious reasons I didn't know before), but I didn't change back the file when I took the box to another friends house. I am not sure why it started acting up all of the sudden this week, as it has been well over two weeks, without any incident. Thanks for all of your help. :cool:
  6. macwise

    macwise New Member

    one more thing

    I forgot to mention that when I changed back to port 25, restarted apache, and flushed the queue, everything cleared out real fast, except for one email. Any guesses who it was going to? Right, AOL. I guess they blocked my server due to non-protocol connection attempts to port 26. hehe. Any ideas how I might get them to relinquish this title of hoodlum that they have so graciously bestowed upon me? Or am I to be blessed with this title forevermore?

    Thanks again for your responses.
  7. falko

    falko Super Moderator

    I'd ask AOL's support team. :)
    (BTW, I didn't know there are still people who use AOL... :D )

Share This Page