postfix questions

Discussion in 'Developers' Forum' started by Jesse Norell, Aug 13, 2015.

  1. Jesse Norell

    Jesse Norell Active Member

    I'm looking at adding some postfix config enhancements and had some questions:

    Is there a minimum supported version of postfix in ispconfig?

    Is there a standard/preferred method to handle version-specific settings? Eg. could test postconf -d mail_version output and write version-dependent configuation. Or could put a checkbox/handle in the UI and let administrators turn things on if they want (and presumably know what they're doing). Is this done anywhere already as an example?

    Is there a reason the submission service (port 587) isn't setup by default? Is there any opposition to doing so?

    Same for smtps on 465? I wouldn't mind seeing a checkbox on this one and defaulting to disabled, as I believe smtps is deprecated in favor of submission+STARTTLS. You do still run into old mail clients that require it now and then (eg. I think our office copier supports smtps but not starttls), so it probably is needed in some places.
    Last edited: Aug 13, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is probably one, but I can't say you which one as ispconfig still works on e.g. centos 5 and Debian 5.

    We use both ways in ispconfig, depending on the task and service that is configured. If you want to add a checkbox then add it under System > server config > mail.

    Submision is setup by default, please see ispconfig perfect server installation instructions. Maybe you missed parts of the postfix chapter on your server.

    I don't see a reason why it should be removed as it does not harm and is still in use. I just had a client yesterday that needed it. Normally the admin decides if he want to enable it during installation of the perfect server setup, so if you don't want to use it then just don't activate it during install. Off course we can add such an option but is it really turned on or off by someone after installation?
  3. Jesse Norell

    Jesse Norell Active Member

    Just digging up some info, debian 5 had postfix 2.5.5 while centos 5 had 2.3.3.
  4. sjau

    sjau Local Meanie Moderator

    debian 5 if out of support. Wheezy is oldstable and if you go with debian, better go with Jessie

Share This Page