Postfix / Procmail does not deliver to right local location

Discussion in 'Installation/Configuration' started by daFritz84, Sep 26, 2008.

  1. daFritz84

    daFritz84 New Member

    Hi all,

    I've setup ispconfig on a CentOS 4.7 System and I'm using postfix as my email server. All seems fine so far since I can send and receive emails.

    I believe that the emails are stored in a wrong maildir since I cannot see them in UebiMiau Webmail or in a local mail client, but I see them on my harddrive. :confused:

    Any clue how comes that?
    If you need to have some further insights in my configuration, let me know ...

    some part of my maillog:
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: connect from mail.gmx.net[213.165.64.20]
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: 32E70808A: client=mail.gmx.net[213.165.64.20]
    Sep 26 23:13:31 root86 postfix/cleanup[27047]: 32E70808A: message-id=<[email protected]>
    Sep 26 23:13:31 root86 postfix/qmgr[27039]: 32E70808A: from=<_obfuscatedaddress_>, size=1248, nrcpt=1 (queue active)
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: disconnect from mail.gmx.net[213.165.64.20]
    Sep 26 23:13:31 root86 sendmail[27053]: m8QLDVAt027053: from=stefan.seifried, size=127, class=0, nrcpts=1, msgid=<[email protected]>, [email protected]
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: connect from localhost[127.0.0.1]
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: setting up TLS connection from localhost[127.0.0.1]
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: TLS connection established from localhost[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Sep 26 23:13:31 root86 sendmail[27053]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: 8AB668244: client=localhost[127.0.0.1]
    Sep 26 23:13:31 root86 postfix/cleanup[27047]: 8AB668244: message-id=<[email protected]>
    Sep 26 23:13:31 root86 postfix/qmgr[27039]: 8AB668244: from=<[email protected]>, size=761, nrcpt=1 (queue active)
    Sep 26 23:13:31 root86 sendmail[27053]: m8QLDVAt027053: [email protected], ctladdr=stefan.seifried (10006/10005), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30127, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 8AB668244)
    Sep 26 23:13:31 root86 postfix/smtpd[27042]: disconnect from localhost[127.0.0.1]
    Sep 26 23:13:31 root86 postfix/local[27048]: 32E70808A: to=<stefn.seifried_at_fakedomain.at>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 26 23:13:31 root86 postfix/qmgr[27039]: 32E70808A: removed
    Sep 26 23:13:31 root86 postfix/local[27056]: 8AB668244: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 26 23:13:31 root86 postfix/qmgr[27039]: 8AB668244: removed
    Sep 26 23:14:28 root86 dovecot: pop3-login: Login: user=<stefan.seifried>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 26 23:14:28 root86 dovecot: POP3(stefan.seifried): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Sep 26 23:14:34 root86 dovecot: pop3-login: Login: user=<stefan.seifried>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 26 23:14:34 root86 dovecot: POP3(stefan.seifried): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Sep 26 23:16:51 root86 postfix/anvil[27045]: statistics: max connection rate 1/60s for (smtp:213.165.64.20) at Sep 26 23:13:31
    Sep 26 23:16:51 root86 postfix/anvil[27045]: statistics: max connection count 1 for (smtp:213.165.64.20) at Sep 26 23:13:31
    Sep 26 23:16:51 root86 postfix/anvil[27045]: statistics: max cache size 1 at Sep 26 23:13:31
    Sep 26 23:20:12 root86 dovecot: pop3-login: Login: user=<stefan.seifried>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 26 23:20:12 root86 dovecot: POP3(stefan.seifried): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Sep 26 23:22:12 root86 dovecot: imap-login: Login: user=<stefan.seifried>, method=PLAIN, rip=xx.xx.xx.xx, lip=xx.xx.xx.xx
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please enable the maildir checkbox under management > server > settings in ispconfig.
     
  3. daFritz84

    daFritz84 New Member

    Hi Till,

    I already enabled the checkbox. And the mail is delivered to the location stated in /etc/passwd. But I think the user directory path's are rather strange.

    e.g.:
    Code:
    stefan.seifried:x:10006:10005:Stefan Seifried:/home/tmp/install_ispconfig/web5:/bin/false
    For your information /home/tmp/install_ispconfig was my directory for installation. But if I follow the path I can find my email in there.

    Any ideas why ispconfig uses that path when entering the mail users in my /etc/passwd?

    Thanks,
    Stefan
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This path is indeed starnge. Did you install ISPConfig with its installer or did you installed the sql dump manually?
     
  5. daFritz84

    daFritz84 New Member

    I used the installer. I prepared my system according to the tutorial for centos 4.6 since 4.7 was not available.

    The root server itself I'm preparing was originally delivered with CentOS 4.7 and BlueQuartz. But I wiped off BlueQuartz since it is discontinued for some time now :rolleyes:.
     
  6. daFritz84

    daFritz84 New Member

    Hi, I resolved the problem by editing the dovecot mail_location property to point to the right place. However since I find the used directories very strange I did a clean reinstallatio and now I have also more convenient pathes.

    Thanks, for your help attempts Till
     

Share This Page