Postfix problems in SUSE 10.2/ISPConfig

Discussion in 'Installation/Configuration' started by jokn, Dec 12, 2007.

  1. jokn

    jokn New Member

    Hi all!

    First of all, sorry about the novell length post, hope you can stay awake through it all! :)

    Hope someone can help me out, I'm doing pretty much the worst thing anyone can do, I'm running my employers web hosting service on a SUSE 10.2 machine without knowing very much about Linux.... (and I'm pretty much a full time Microsoft/Cisco consultant, so I'm more or less sysadmin by night)

    Here's the problem, September 30th a customer called and said people mailing to them just get bounced, "unknown user", I read the logs and saw the message:

    "Sep 30 13:12:43 suse postfix/postmap[13799]: fatal: open database /etc/postfix/virtusertable.db: No such file or directory"

    I searched the forums and found the postmap/restart workaround figuring the bug would just get fixed by an online update (yes, most of my consulting is Microsoft-based, go figure...) but there seem to be no solution out there. In desperation I installed another machine exactly the same way, the brilliant Perfect setup SUSE 10.2 by Falko, and sure enough, I got the same error, every time I changed something in the web interface of ISPConfig I got the error message above and emails would bounce:

    Dec 12 12:04:49 suse postfix/smtpd[9371]: NOQUEUE: reject: RCPT from[]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]_company.tld> to=<[email protected]> proto=ESMTP helo=<>

    Addresses of course supressed, but you get the idea. As you can see by the time stamp I'm still getting screamed at by my less than patient customers...

    Now for the fun part, since I was just running my own and a test website on the second test machine I went ahead and did an upgrade as soon as I finished downloading the 10.3 DVD, went well, the problems with the virtusertable.db is no longer there, I can change whatever I want and it just reloads as it's supposed to. Only thing that stopped working was TLS AUTH or whatever it's called, but I just had to enable it via chkconfig again and that too started working. The problem now is in three parts:

    1. I need a script (yesterday or rather in October) that runs via cron that can read a line/word from /var/log/mail.err (the virtusertable.db error) and act upon it by running my fixmail-script (just postmap/restart), anyone know of a script like that I´d be grateful. Have to have something until this is solved, I can't stay up 24/7 with a tail-f /var/log/mail....
    2. Does anyone know where one may find the latest Postfix-rpm for SUSE, tried yast but it said latest 2.3.2 and installed 2.3.2 but I might be doing it wrong, self taught by night doesn't really cut it unless its Microsoft... Don't wanna go with a source compilation on the production machine either, I have 65 custumers there, already pissed off, but if I end up reinstalling the machine I might get lynched... Perhaps I have to change the repo server to get a later package?
    3. For a full 10.3 upgrade (I know I'm getting nightmares just writing these words), any tips/warnings/anything? If that is how I need to proceed to get out of this I'm gonna get a one-way ticket far away first....

    Thanks, hope you have some good tips for me!

  2. falko

    falko Super Moderator ISPConfig Developer

    Maybe monit can do something like this:


    I wouldn't try to upgrade a SUSE system (in fact, I wouldn't even install it on a production system), but that's just me. I think it cold turn into a nightmare... :eek:
  3. jokn

    jokn New Member

    I'll try it out, thanks!

    Thanks, found it, I´ll try it out after some serious backing up...

    Kind of sorry right now that the first hit I got when I searched for setup instructions for Linux and web control panel was your SUSE one with ISPConfig.... :( Any thaughts on a different dist if I end up having to do it all over again? I know that's not the kind of question we ask but heck, right now I'm trying anything...


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You should take a look at debian.
  5. jokn

    jokn New Member

    I will, a test machine booting right now and Falko's Perfect setup on the screen.


  6. jbravo

    jbravo New Member

    Just go to site and enter "postfix" in search field. I'm sure you will find latest postfix rpm's.

    And maybe commercial SUSE edition - SLES is for You.

    GreetZ .:JbRaVo:.
  7. jokn

    jokn New Member

    Hmm, wonder why I didn't find that page when I searched the site for "rpm download"...

    I'm gonna give the upgraded postfix-installation a chance, if nothing else works I just might try a whole new dist, but I don't think SUSE, commercial or not, will get another chance then.

    Thanks though!

  8. falko

    falko Super Moderator ISPConfig Developer

    Definitely Debian! :)

Share This Page