Postfix problems after migrating ISPCFG3

Discussion in 'Server Operation' started by Ovidiu, Nov 20, 2015.

  1. Ovidiu

    Ovidiu Active Member

    Old machine was physical, new machine is virtual running inside LXC on hypervisor: proxmox.

    getting these postmaster notifications:
    Code:
    Mail Delivery System <MAILER-DAEMON@alfred.ict-consult.co.za>
    10:38 (4 minutes ago)
    
    to Postmaster
    Transcript of session follows.
    
    Out: 220 alfred.ict-consult.co.za ESMTP Postfix (Debian/GNU)
    In:  EHLO localhost
    Out: 250-alfred.ict-consult.co.za
    Out: 250-PIPELINING
    Out: 250-SIZE
    Out: 250-VRFY
    Out: 250-ETRN
    Out: 250-STARTTLS
    Out: 250-AUTH PLAIN LOGIN
    Out: 250-AUTH=PLAIN LOGIN
    Out: 250-ENHANCEDSTATUSCODES
    Out: 250-8BITMIME
    Out: 250 DSN
    In:  MAIL FROM:<sender1@sa-tax.co.za> BODY=7BIT
    Out: 250 2.1.0 Ok
    In:  RCPT TO:<sender2@sa-tax.co.za> ORCPT=rfc822;sender2@sa-tax.co.za
         NOTIFY=SUCCESS,FAILURE,DELAY
    Out: 250 2.1.5 Ok
    In:  DATA
    Out: 354 End data with <CR><LF>.<CR><LF>
    Out: 451 4.3.0 Error: queue file write error
    
    Session aborted, reason: lost connection
    also seeing a lot of these errors:
    Code:
    defer service failure
    trace service failure
    I have 32 emails in my deferred queue, all from 1 single sender (one of my client's emails) and I have no idea why.

    Any hitns, tips, what more info can I supply?

    Debian Jessie, ISPCFG3,
    Code:
    postfix -v check
    postfix: name_mask: ipv4
    postfix: inet_addr_local: configured 2 IPv4 addresses
    Code:
    postconf -d | grep mail_version
    mail_version = 2.11.3
    milter_macro_v = $mail_name $mail_version
     
  2. Ovidiu

    Ovidiu Active Member

    I've also noticed that sometimes? not sure if always, amavis gets triggered by one incoming email twice
    Code:
    Nov 20 11:20:33 alfred postfix/smtpd[11845]: NOQUEUE: filter: RCPT from mail.answers4business.co.za[196.30.206.49]: <Services@answers4business.co.za>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<Services@answers4business.co.za> to=<recipient@sa-tax.co.za> proto=ESMTP helo=<mail.answers4business.co.za>
    Nov 20 11:20:33 alfred postfix/smtpd[11845]: NOQUEUE: filter: RCPT from mail.answers4business.co.za[196.30.206.49]: <Services@answers4business.co.za>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<Services@answers4business.co.za> to=<recipient@sa-tax.co.za> proto=ESMTP helo=<mail.answers4business.co.za>
    I know amavis is forwarding to postfix after checking but does that look normal?
     

Share This Page