Postfix Problem

Discussion in 'Server Operation' started by tardomatic, Dec 11, 2007.

  1. tardomatic

    tardomatic New Member


    I have set up postfix to deliver to virtual users using mysql for a number of domains on one machine. This works great when this machine is the final destination for a specific domains emails, and has been working great for months.

    The problem is that one of domains hosted on the machine has their mail hosted by an ISP in POP3 mailboxes, and they don't want that to change. So, I have set up fetchmail that retrieves the emails from a server and forwards it to postfix, and no problems. The users can send and receive emails without issue.

    The problem is that they have a few remote users that use the POP3 accounts and retrieve mail directly from them. These users aren't part of my fetchmail / postfix config, sooooo... when one of the internal users tries to send a mail to one of the remote users, it obivously can't find the remote user in the virtual lookup table, and dies.

    So, my question is... is there a way that I can force Postfix to send emails to a remote SMTP server for certain email addresses with the same domain as my Postfix server...

    If not, has anyone done something like this before? Any suggestions?
  2. falko

    falko Super Moderator ISPConfig Developer

    You can do that with transports. Take a look at
    man 5 transport
  3. tardomatic

    tardomatic New Member

    Thanks :)


    Thanks for the reply... I have tried the transport thing, but it obviously isnt working quite like i understand it to. I basically specified each email address in transport and specified which smtp server to send the mail to. this works great for external addresses, but when local clients send to the server, it has problems (looping)


Share This Page