Postfix problem when adding extra IP.

Discussion in 'Installation/Configuration' started by blackfox123, Feb 4, 2015.

  1. blackfox123

    blackfox123 Member HowtoForge Supporter

    I have ordered a second failover IP for my server - and have added:

    auto eth0:1
    iface eth0:1 inet static
    address 94.23.xxx.xxx

    in my /etc/network/interfaces which activates the IP.

    However now I cannot send mails out from my server. I have tried binding my original IP within postfix conf, but that hasn't seemd to have worked. Am i missing something? I am getting a lot of mails deferred now because postfix throws No Route to Host in my mail logs.

    UPDATE: After a little more poking around, i have disabled eth0:1, ifconfig eth0:1 down.. and the mails go through properly.. with the interface up, the mails get deferred with 'no route to host' still - it's definatley a ip route problem. any ideas appreciated.
     
    Last edited: Feb 4, 2015

Share This Page