Postfix problem, The emails don't arrive to the people

Discussion in 'Server Operation' started by hhhhhh, Jan 13, 2009.

  1. hhhhhh

    hhhhhh New Member

    Hello,

    I received few mails from my users saying that there are few emails that didn't arrive to their Inbox folder.
    There are few from yahoo and others with register domains.

    I saw the mail.log and display the following info:

    Lost connection with q1.netfirms.com[xx.xxx.xx.xx] while receiving the initial server greeting) mail.domain.com

    How can I do to fix it?

    I have ubuntu hardy heron, postfix, php5, mysql...from Perfect Server 8.04 tutorial.

    Hope to hear soon!

    Thank you very much!!

    I forgot to say that I have few virtual sites through sites-available and sites-enabled running in the server. With different IPs.
     
    Last edited: Jan 13, 2009
  2. topdog

    topdog Active Member HowtoForge Supporter

    That is a networking issue you need to check the quality of your network links.
     
  3. hhhhhh

    hhhhhh New Member

    Thanks for your reply topdog,

    My question is, how can I check the quality of my network links?

    Thank you
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any other errors in your mail log? What's in your main.cf?
     
  5. hhhhhh

    hhhhhh New Member

    Hello falko!

    Thanks for your attention.

    main.cf display the following:

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = no
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname =server.nameserver.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination =server.nameserver.com, locahost.nameserver.com, localhost.localdomain, localhost
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_command = 
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    And mail.log & mail.err in attached files.

    Hope to hear you soon!!
     

    Attached Files:

  6. falko

    falko Super Moderator ISPConfig Developer

    It seems as if your web application does not specify a recipient address.
     
  7. hhhhhh

    hhhhhh New Member

    Hello falko!

    Yes, it was when I try myself, I forgot to add the email.

    If you see in mail.log search the following IP: 38.113.184.171
    It is the problem, only on that email and host.

    I really don't know what happened.

    What do you think about this?

    Hope to hear you soon

    Thank you!!!
     
  8. falko

    falko Super Moderator ISPConfig Developer

  9. hhhhhh

    hhhhhh New Member

    Hi falko!

    Yes, I checked all Ips located in my server 2 or 3 days ago (When I discovered the issue) and all is correct. Any of them are blacklisted.

    I contacted with netfirms about the issue and they responded me the following:

    Code:
    Hello,
    
    Thank you for your inquiry.
    
    Upon further investigations it seems that the mail server that is trying to send you 
    
    email is in violation of RFC1912 2.1. Please note that RFC 1912 2.1 is one of many 
    
    Internet standards that have been created. All RFC's are currently maintained by IETF 
    
    Secretariat. For more information about RFC's please visit 
    
    http://www.ietf.org/rfc.html 
    
    The Netfirms mail servers  require senders to send  email from a mail server that has 
    
    a valid reverse DNS entry. This is common practice for most e-mail servers on the 
    
    Internet and helps reduce spammed messages.
    
    According to our investigations (see [http://www.blacklistalert.org/]), it appears that 
    
    you're unable to receive email from [65.54.245.40]  because the sender's 
    
    mail server does not contain a valid reverse DNS entry. 
    
    NS-Status of 65.54.245.40:
    
    Reverse DNS (PTR) exists and claims to be: mx2.hotmail.com.
    
    Forward DNS for mx2.hotmail.com is: 65.54.244.168.
    
    WARNING: Forward-DNS does NOT match Reverse-DNS.
    DNS is INCONSISTENT.
    Please request your Admin or Provider to fix this.
    
    To resolve this issue, we suggest that the E-mail Provider be contacted to determine 
    
    if they can send their mail from a mail server with a valid reverse DNS entry.
    
    This information is also available to you by browsing to 
    
    http://www.netfirms.com/support and doing a keyword search on "can't receive email ".
    
    
    
    Regards,
    
    Lucy
    Netfirms Support Team
    My IP is not the displayed above. I think that netfirms email is a robot or something like that. This IP is from hotmail.com & Microsoft host.

    And yesterday I received that from them:

    Code:
    Hello,
    
    Thank you for your inquiry.
    
    Please contact the mail administrator of 65.54.245.40 and have them install a PTR record (or reverse DNS) for the IP address of your mail servers.  Once this has been done, the mail will be successfully received at Netfirms.
    
    Regards,
    Richard
    Netfirms Support Team
    I think that the problem is from netfirms, what do you think falko?

    Thank you very much!!
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's your mail server's public IP address?
    Does it have a PTR record? You can check like this:
    Code:
    dig -x 1.2.3.4
    (replace 1.2.3.4 with the real IP)
     
  11. hhhhhh

    hhhhhh New Member

    Hi falko!

    Apologize for delay, I was ill these days. :(

    Yes, I have it:

    Code:
    ; <<>> DiG 9.4.2-P1 <<>> -x 1.1.1.1
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39703
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;161.221.17.85.in-addr.arpa.    IN      PTR
    
    ;; ANSWER SECTION:
    161.221.17.85.in-addr.arpa. 86400 IN    PTR     hosted-by.leaseweb.com.
    
    ;; AUTHORITY SECTION:
    221.17.85.in-addr.arpa. 97560   IN      NS      ns1.leaseweb.nl.
    221.17.85.in-addr.arpa. 97560   IN      NS      ns4.leaseweb.net.
    221.17.85.in-addr.arpa. 97560   IN      NS      ns5.leaseweb.nl.
    
    ;; ADDITIONAL SECTION:
    ns1.leaseweb.nl.        6011    IN      A       62.212.64.121
    ns4.leaseweb.net.       92411   IN      A       62.212.78.199
    ns5.leaseweb.nl.        6011    IN      A       83.149.64.123
    
    ;; Query time: 3 msec
    ;; SERVER: 85.17.150.123#53(85.17.150.123)
    ;; WHEN: Tue Jan 20 02:23:54 2009
    ;; MSG SIZE  rcvd: 205
    
    1.1.1.1 is my real IP.

    The answer is showing: hosted-by.leaseweb.com.
    I think that should be www.mydomain.com or hosted-by.mydomain.com isn't it?

    I went to reverse DNS lookup in leaseweb panel and show the same: hosted-by.leaseweb.com.
    I've changed to www.mydomain.com
    Will be good?
    How many time should take it to run correctly?

    Thank you for your patience falko!
     
    Last edited: Jan 20, 2009
  12. falko

    falko Super Moderator ISPConfig Developer

    No, all that is important is that hosted-by.leaseweb.com also points back to 1.1.1.1. You can check with
    Code:
    dig hosted-by.leaseweb.com
    If it's showing a different IP, than other mail servers will most likely reject your emails because the PTR and the A records don't match.
     
  13. hhhhhh

    hhhhhh New Member

    Hello falko!

    Yes, I have it solved.

    I call to leaseweb. He said me that I must to change hosted-by.leaseweb.com to something.mydomain.com

    I tried to send mails to the boxes which had problems in the past and run like a charm.

    If anyone read this post in future the solution was:

    1- Go to DNS Lookup section in your Hosting Control Panel
    2- Change the default name to your something.yourdomain.com
    3- Wait few time to look the changes.

    Thank you very very much!!!
     

Share This Page