Postfix problem, The emails don't arrive to the people

Discussion in 'Server Operation' started by hhhhhh, Jan 13, 2009.

  1. hhhhhh

    hhhhhh New Member


    I received few mails from my users saying that there are few emails that didn't arrive to their Inbox folder.
    There are few from yahoo and others with register domains.

    I saw the mail.log and display the following info:

    Lost connection with[] while receiving the initial server greeting)

    How can I do to fix it?

    I have ubuntu hardy heron, postfix, php5, mysql...from Perfect Server 8.04 tutorial.

    Hope to hear soon!

    Thank you very much!!

    I forgot to say that I have few virtual sites through sites-available and sites-enabled running in the server. With different IPs.
    Last edited: Jan 13, 2009
  2. topdog

    topdog Active Member HowtoForge Supporter

    That is a networking issue you need to check the quality of your network links.
  3. hhhhhh

    hhhhhh New Member

    Thanks for your reply topdog,

    My question is, how can I check the quality of my network links?

    Thank you
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any other errors in your mail log? What's in your
  5. hhhhhh

    hhhhhh New Member

    Hello falko!

    Thanks for your attention. display the following:

    # See /usr/share/postfix/ for a commented, more complete version
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    readme_directory = no
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination,, localhost.localdomain, localhost
    relayhost = 
    mynetworks =
    mailbox_command = 
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    And mail.log & mail.err in attached files.

    Hope to hear you soon!!

    Attached Files:

  6. falko

    falko Super Moderator ISPConfig Developer

    It seems as if your web application does not specify a recipient address.
  7. hhhhhh

    hhhhhh New Member

    Hello falko!

    Yes, it was when I try myself, I forgot to add the email.

    If you see in mail.log search the following IP:
    It is the problem, only on that email and host.

    I really don't know what happened.

    What do you think about this?

    Hope to hear you soon

    Thank you!!!
  8. falko

    falko Super Moderator ISPConfig Developer

  9. hhhhhh

    hhhhhh New Member

    Hi falko!

    Yes, I checked all Ips located in my server 2 or 3 days ago (When I discovered the issue) and all is correct. Any of them are blacklisted.

    I contacted with netfirms about the issue and they responded me the following:

    Thank you for your inquiry.
    Upon further investigations it seems that the mail server that is trying to send you 
    email is in violation of RFC1912 2.1. Please note that RFC 1912 2.1 is one of many 
    Internet standards that have been created. All RFC's are currently maintained by IETF 
    Secretariat. For more information about RFC's please visit  
    The Netfirms mail servers  require senders to send  email from a mail server that has 
    a valid reverse DNS entry. This is common practice for most e-mail servers on the 
    Internet and helps reduce spammed messages.
    According to our investigations (see []), it appears that 
    you're unable to receive email from []  because the sender's 
    mail server does not contain a valid reverse DNS entry. 
    NS-Status of
    Reverse DNS (PTR) exists and claims to be:
    Forward DNS for is:
    WARNING: Forward-DNS does NOT match Reverse-DNS.
    Please request your Admin or Provider to fix this.
    To resolve this issue, we suggest that the E-mail Provider be contacted to determine 
    if they can send their mail from a mail server with a valid reverse DNS entry.
    This information is also available to you by browsing to  and doing a keyword search on "can't receive email ".
    Netfirms Support Team
    My IP is not the displayed above. I think that netfirms email is a robot or something like that. This IP is from & Microsoft host.

    And yesterday I received that from them:

    Thank you for your inquiry.
    Please contact the mail administrator of and have them install a PTR record (or reverse DNS) for the IP address of your mail servers.  Once this has been done, the mail will be successfully received at Netfirms.
    Netfirms Support Team
    I think that the problem is from netfirms, what do you think falko?

    Thank you very much!!
  10. falko

    falko Super Moderator ISPConfig Developer

    What's your mail server's public IP address?
    Does it have a PTR record? You can check like this:
    dig -x
    (replace with the real IP)
  11. hhhhhh

    hhhhhh New Member

    Hi falko!

    Apologize for delay, I was ill these days. :(

    Yes, I have it:

    ; <<>> DiG 9.4.2-P1 <<>> -x
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39703
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3
    ;    IN      PTR
    ;; ANSWER SECTION: 86400 IN    PTR
    ;; AUTHORITY SECTION: 97560   IN      NS 97560   IN      NS 97560   IN      NS
    ;; ADDITIONAL SECTION:        6011    IN      A       92411   IN      A        6011    IN      A
    ;; Query time: 3 msec
    ;; SERVER:
    ;; WHEN: Tue Jan 20 02:23:54 2009
    ;; MSG SIZE  rcvd: 205 is my real IP.

    The answer is showing:
    I think that should be or isn't it?

    I went to reverse DNS lookup in leaseweb panel and show the same:
    I've changed to
    Will be good?
    How many time should take it to run correctly?

    Thank you for your patience falko!
    Last edited: Jan 20, 2009
  12. falko

    falko Super Moderator ISPConfig Developer

    No, all that is important is that also points back to You can check with
    If it's showing a different IP, than other mail servers will most likely reject your emails because the PTR and the A records don't match.
  13. hhhhhh

    hhhhhh New Member

    Hello falko!

    Yes, I have it solved.

    I call to leaseweb. He said me that I must to change to

    I tried to send mails to the boxes which had problems in the past and run like a charm.

    If anyone read this post in future the solution was:

    1- Go to DNS Lookup section in your Hosting Control Panel
    2- Change the default name to your
    3- Wait few time to look the changes.

    Thank you very very much!!!

Share This Page