Postfix problem on CentOS 5.3

Discussion in 'Installation/Configuration' started by mmk, Aug 26, 2009.

  1. mmk

    mmk New Member

    Hi. I followed the tutorial: Perfect Server - CentOS 5.3 x86_64 [ISPConfig 3].

    At first, thanks for bringing this wonderful tutorial. Everything worked out as expected, with only minor issues. However, I have a problem with postfix. When the service starts, everything seems to be OK, but the mail log shows the following error:
    Code:
    fatal: unsupported dictionary type: mysql
    The SMTP port (25) is open, but after I connect nothing happens.

    I read in another forum that this means postfix lacks mysql support. Their suggestion is to remove the original postfix package and install the following package from the CentOS Plus repository:
    Code:
    postfix-2.3.3-2.1.centos.mysql_pgsql.x86_64.rpm
    Is it safe to do this? Will this break the ISPConfig's postfix configuration?

    Thank you.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    The tutorial shows how to build Postfix with MySQL support...
     
  3. mmk

    mmk New Member

    Thank you for the prompt answer falko.

    Actually, I jumped over the whole 11 Apply Quota Patch To Postfix part since I don't need quota. I did not realise this chapter was also dealing with MySQL support.

    Will reinstalling Postfix with proper MySQL support mess up with ISPConfig's configuration? If yes, than how can I fix the problem?

    Thanks.
     
    Last edited: Aug 27, 2009
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can run a ispconfig update afterwards and select to reconfigure the services.
     
  5. kedar

    kedar New Member

    I have installed this RPM and everything works as expected. I have CentOS 5.2
     
  6. mmk

    mmk New Member

    Everything worked out perfectly. Thanks everyone for your help. I really appreciate it.
     

Share This Page